# CVE-2026-27461: Pimcore vulnerable to SQL injection via unsanitized filter value in Dependency Dao RLIKE clause

> An authenticated admin can exploit SQL injection in dependency filters to extract the full database, including password hashes.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-vxg3-v4p6-f3fp

## What is CVE-2026-27461?

CVE-2026-27461 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 24 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Pimcore is an Open Source Data & Experience Management Platform. In versions up to and including 11.5.14.1 and 12.3.2, the filter query parameter in the dependency listing endpoints is JSON-decoded and the value field is concatenated directly into RLIKE clauses without sanitization or parameterized queries. Exploiting this issue requires admin authentication. An attacker with admin panel access can extract the full database including password hashes of other admin users. Version 12.3.3 contains a patch.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-27461?

4 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions to 11.5.14.1 | None |
| `pimcore/pimcore` | Packagist | All versions to 11.5.14.1 | None |
| `pimcore/pimcore` | Packagist | From 12.0.0 | 12.3.3 |
| `pimcore/pimcore` | Packagist | From 12.0.0 | 12.3.3 |

Products: Pimcore Pimcore.

## How do I fix CVE-2026-27461?

Upgrade pimcore/pimcore to 12.3.3 or later.

## Is CVE-2026-27461 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27461 exists.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27461 and fix it if it is affected.

What it is: CVE-2026-27461 is a medium-severity SQL injection vulnerability in Pimcore Pimcore, published on 24 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27461 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions up to 11.5.14.1; no fix listed
- pimcore/pimcore (Packagist): affected all versions up to 11.5.14.1; no fix listed
- pimcore/pimcore (Packagist): affected from 12.0.0; fixed in 12.3.3
- pimcore/pimcore (Packagist): affected from 12.0.0; fixed in 12.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27461/ (Markdown: https://insights.sbomify.com/CVE-2026-27461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27461
- OSV: https://osv.dev/vulnerability/CVE-2026-27461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27461/
Summaries are generated and may contain mistakes; the official description above is the record.
