{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27464 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-27464 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-27464 is a high-severity code injection vulnerability in metabase, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27464 and fix it if it is affected.\n\nWhat it is: CVE-2026-27464 is a high-severity code injection vulnerability in metabase, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27464 in the wild and no public exploit code.\n\nAffected product: metabase. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27464/ (Markdown: https://insights.sbomify.com/CVE-2026-27464/index.md)","id":"CVE-2026-27464","markdown":"https://insights.sbomify.com/CVE-2026-27464/index.md","name":"CVE-2026-27464","record":{"aliases":["GHSA-vcj8-rcm8-gfj9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Metabase analytics platform","requires_auth":"low_privilege","summary":"Authenticated users can exploit server-side template injection in notifications to execute code and extract sensitive database credentials.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"metabase","vendor":"metabase"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Metabase is an open-source data analytics platform. In versions prior to 0.57.13 and versions 0.58.x through 0.58.6, authenticated users are able to retrieve sensitive information from a Metabase instance, including database access credentials. During testing, it was confirmed that a low-privileged user can extract sensitive information including database credentials, into the email body via template evaluation. This issue has been fixed in versions 0.57.13 and 0.58.7. To workaround this issue, users can disable notifications in their Metabase instance to disallow access to the vulnerable endpoints.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Metabase: Server-Side Template Injection via Notifications Endpoint Leads to RCE","id":"CVE-2026-27464","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"Fleet: Sensitive Google Calendar credentials disclosed to low-privileged users","id":"CVE-2026-27465"},"packages":[],"prev":{"headline":"Combodo iTop: Version disclosure via login page logo","id":"CVE-2026-27463"},"products":["metabase"],"published":"2026-02-21","related":[{"cvss_score":10,"headline":"Metabase SQL Injection","id":"CVE-2026-72898","kev_date_added":"2026-08-11","published":"2026-08-10"},{"cvss_score":10,"headline":"Metabase GeoJSON API Local File Inclusion","id":"CVE-2021-41277","kev_date_added":"2024-11-12","published":"2021-11-17"},{"cvss_score":10,"headline":"Metabase: Remote Code Execution via Snowflake JDBC Driver Arbitrary File Write","id":"CVE-2026-50148","kev_date_added":null,"published":"2026-07-15"},{"cvss_score":10,"headline":"Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint","id":"CVE-2023-37470","kev_date_added":null,"published":"2023-08-04"},{"cvss_score":9.9,"headline":"Metabase: Unsafe Deserialization of H2 Query Results","id":"CVE-2026-59827","kev_date_added":null,"published":"2026-07-09"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-38646","kev_date_added":null,"published":"2023-07-21"},{"cvss_score":9.1,"headline":"Metabase: Arbitrary Code Execution via Database Connection Detail Bypass","id":"CVE-2026-59826","kev_date_added":null,"published":"2026-07-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-24","vendors":["metabase"]},"summary":"Authenticated users can exploit server-side template injection in notifications to execute code and extract sensitive database credentials.","url":"https://insights.sbomify.com/CVE-2026-27464/"}