# CVE-2026-27468: Mastodon may allow unconfirmed FASP to make subscriptions

> Unapproved FASP clients can subscribe to events and request backfill, causing information leaks and denial of service on Mastodon servers with experimental features enabled.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** BIT-mastodon-2026-27468, GHSA-qgmm-vr4c-ggjg

## What is CVE-2026-27468?

CVE-2026-27468 is a medium-severity missing authorization vulnerability in mastodon, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon is a free, open-source social network server based on ActivityPub. FASP registration requires manual approval by an administrator. In versions 4.4.0 through 4.4.13 and 4.5.0 through 4.5.6, actions performed by a FASP to subscribe to account/content lifecycle events or to backfill content did not check properly whether the FASP was actually approved. This only affects Mastodon servers that have opted in to testing the experimental FASP feature by setting the environment variable `EXPERIMENTAL_FEATURES` to a value including `fasp`. An attacker can make subscriptions and request content backfill without approval by an administrator. Done once, this leads to minor information leak of URIs that are publicly available anyway. But done several times this is a serious vector for DOS, putting pressure on the sidekiq worker responsible for the `fasp` queue. The fix is included in the 4.4.14 and 4.5.7 releases. Admins that are actively testing the experimental "fasp" feature should update their systems. Servers not using the experimental feature flag `fasp` are not affected.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-27468?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | From 4.4.0 | 4.4.14, 4.5.7 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2026-27468?

Upgrade mastodon to a fixed version for your release line: 4.4.14 or 4.5.7.

## Is CVE-2026-27468 being exploited?

There is no known exploitation of CVE-2026-27468 in the wild and no public exploit code.

## Other vulnerabilities in mastodon

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27468 and fix it if it is affected.

What it is: CVE-2026-27468 is a medium-severity missing authorization vulnerability in mastodon, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27468 in the wild and no public exploit code.

Affected packages and fixed versions:
- mastodon (Bitnami): affected from 4.4.0; fixed in 4.4.14, 4.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27468/ (Markdown: https://insights.sbomify.com/CVE-2026-27468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27468
- OSV: https://osv.dev/vulnerability/CVE-2026-27468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27468/
Summaries are generated and may contain mistakes; the official description above is the record.
