# CVE-2026-27478: Unity Catalog has a JWT Issuer Validation Bypass Allows Complete User Impersonation

> Attackers can impersonate any user by bypassing JWT issuer validation in Unity Catalog's token exchange endpoint, leading to complete account takeover.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-qqcj-rghw-829x

## What is CVE-2026-27478?

CVE-2026-27478 is a critical authentication bypass vulnerability in unitycatalog, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unity Catalog is an open, multi-modal Catalog for data and AI. In 0.4.0 and earlier, a critical authentication bypass vulnerability exists in the Unity Catalog token exchange endpoint (/api/1.0/unity-control/auth/tokens). The endpoint extracts the issuer (iss) claim from incoming JWTs and uses it to dynamically fetch the JWKS endpoint for signature validation without validating that the issuer is a trusted identity provider.

Weakness: CWE-346 (Origin Validation Error), CWE-290 (Authentication Bypass by Spoofing), CWE-1390 (Weak Authentication)

## Which versions are affected by CVE-2026-27478?

2 open source packages ship an affected version, including io.unitycatalog:unitycatalog-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.unitycatalog:unitycatalog-server` | Maven | All versions | 0.4.1 |
| `io.unitycatalog:unitycatalog-server` | Maven | All versions | 0.4.1 |

Products: Unitycatalog Unitycatalog.

## How do I fix CVE-2026-27478?

Upgrade io.unitycatalog:unitycatalog-server to 0.4.1 or later.

## Is CVE-2026-27478 being exploited?

There is no known exploitation of CVE-2026-27478 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27478 and fix it if it is affected.

What it is: CVE-2026-27478 is a critical authentication bypass vulnerability in unitycatalog, published on 11 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27478 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.unitycatalog:unitycatalog-server (Maven): affected all versions; fixed in 0.4.1
- io.unitycatalog:unitycatalog-server (Maven): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27478/ (Markdown: https://insights.sbomify.com/CVE-2026-27478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27478
- OSV: https://osv.dev/vulnerability/CVE-2026-27478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27478/
Summaries are generated and may contain mistakes; the official description above is the record.
