# CVE-2026-27483: MindsDB has Path Traversal in /api/files Leading to Remote Code Execution

> An authenticated attacker can exploit a path traversal flaw in the file upload API to write arbitrary files and execute remote code on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** GHSA-4894-xqv6-vrfq, PYSEC-2026-2205

## What is CVE-2026-27483?

CVE-2026-27483 is a high-severity path traversal vulnerability in mindsdb, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MindsDB is a platform for building artificial intelligence from enterprise data. Prior to version 25.9.1.1, there is a path traversal vulnerability in Mindsdb's /api/files interface, which an authenticated attacker can exploit to achieve remote command execution. The vulnerability exists in the "Upload File" module, which corresponds to the API endpoint /api/files. Since the multipart file upload does not perform security checks on the uploaded file path, an attacker can perform path traversal by using `../` sequences in the filename field. The file write operation occurs before calling clear_filename and save_file, meaning there is no filtering of filenames or file types, allowing arbitrary content to be written to any path on the server. Version 25.9.1.1 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-27483?

3 open source packages ship an affected version, including mindsdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mindsdb` | PyPI | All versions | 25.9.1.1 |
| `mindsdb` | PyPI | All versions | 25.9.1.1 |
| `mindsdb` | PyPI | All versions | 25.9.1.1 |

Products: Mindsdb Mindsdb.

## How do I fix CVE-2026-27483?

Upgrade mindsdb to 25.9.1.1 or later.

## Is CVE-2026-27483 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27483 exists.

Public exploit code:

- MindsDB Path Traversal to RCE PoC (github_poc): https://github.com/thewhiteh4t/cve-2026-27483
- A containerized enterprise-style lab for researching and defending against CVE-2026-27483. (github_poc): https://github.com/nabhan-mohy/cve-2026-27483-lab
- MindsDB  25.9.1.1 - Path Traversal (exploitdb)
- MindsDB - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-27483.yaml

## Other vulnerabilities in mindsdb

- [CVE-2024-24759](https://insights.sbomify.com/CVE-2024-24759/): MindsDB Vulnerable to Bypass of SSRF Protection with DNS Rebinding (critical 9.3)
- [CVE-2023-50731](https://insights.sbomify.com/CVE-2023-50731/): MindsDB has arbitrary file write in file.py (critical 9.1)
- [CVE-2023-38699](https://insights.sbomify.com/CVE-2023-38699/): MindsDB 'Call to requests with verify=False disabling SSL certificate checks, security issue.' issue (critical 9.1)
- [CVE-2024-45856](https://insights.sbomify.com/CVE-2024-45856/): MindsDB Cross-site Scripting vulnerability (critical 9.0)
- [CVE-2024-45846](https://insights.sbomify.com/CVE-2024-45846/): MindsDB Eval Injection vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27483 and fix it if it is affected.

What it is: CVE-2026-27483 is a high-severity path traversal vulnerability in mindsdb, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27483 exists.

Affected packages and fixed versions:
- mindsdb (PyPI): affected all versions; fixed in 25.9.1.1
- mindsdb (PyPI): affected all versions; fixed in 25.9.1.1
- mindsdb (PyPI): affected all versions; fixed in 25.9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27483/ (Markdown: https://insights.sbomify.com/CVE-2026-27483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27483
- OSV: https://osv.dev/vulnerability/CVE-2026-27483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27483/
Summaries are generated and may contain mistakes; the official description above is the record.
