# CVE-2026-27492: Lettermint Node.js SDK leaks email properties to unintended recipients when client instance is reused

> Reusing a client instance leaks previous email properties to unintended recipients, exposing sensitive data in transactional flows.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-49pc-8936-wvfp

## What is CVE-2026-27492?

CVE-2026-27492 is a medium-severity vulnerability in lettermint-node, published on 21 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lettermint Node.js SDK is the official Node.js SDK for Lettermint. In versions 1.5.0 and below, email properties (such as to, subject, html, text, and attachments) are not reset between sends when a single client instance is reused across multiple .send() calls. This can cause properties from a previous send to leak into a subsequent one, potentially delivering content or recipient addresses to unintended parties. Applications sending emails to different recipients in sequence — such as transactional flows like password resets or notifications — are affected. This issue has been fixed in version 1.5.1.

Weakness: CWE-488 (Exposure of Data Element to Wrong Session)

## Which versions are affected by CVE-2026-27492?

2 open source packages ship an affected version, including lettermint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lettermint` | npm | All versions | 1.5.1 |
| `lettermint` | npm | All versions | 1.5.1 |

Products: Lettermint Lettermint.

## How do I fix CVE-2026-27492?

Upgrade lettermint to 1.5.1 or later.

## Is CVE-2026-27492 being exploited?

There is no known exploitation of CVE-2026-27492 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27492 and fix it if it is affected.

What it is: CVE-2026-27492 is a medium-severity vulnerability in lettermint-node, published on 21 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27492 in the wild and no public exploit code.

Affected packages and fixed versions:
- lettermint (npm): affected all versions; fixed in 1.5.1
- lettermint (npm): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27492/ (Markdown: https://insights.sbomify.com/CVE-2026-27492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27492
- OSV: https://osv.dev/vulnerability/CVE-2026-27492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27492/
Summaries are generated and may contain mistakes; the official description above is the record.
