# CVE-2026-27496: n8n has In-Process Memory Disclosure in its Task Runner

> Authenticated users can disclose sensitive in-process memory data via the JavaScript Task Runner if runners are enabled.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 25 Mar 2026
- **Also known as:** GHSA-xvh5-5qg4-x9qp

## What is CVE-2026-27496?

CVE-2026-27496 is a high-severity vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 1.123.22, 2.9.3, and 2.10.1, an authenticated user with permission to create or modify workflows could use the JavaScript Task Runner to allocate uninitialized memory buffers. Uninitialized buffers may contain residual data from the same Node.js process — including data from prior requests, tasks, secrets, or tokens — resulting in information disclosure of sensitive in-process data. Task Runners must be enabled using `N8N_RUNNERS_ENABLED=true`. In external runner mode, the impact is limited to data within the external runner process. The issue has been fixed in n8n versions 1.123.22, 2.10.1 , and 2.9.3. Users should upgrade to this version or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or use external runner mode (`N8N_RUNNERS_MODE=external`) to isolate the runner process. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2026-27496?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.22 |
| `n8n` | npm | All versions | 1.123.22 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.9.3 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.9.3 |
| `n8n` | npm | From 2.10.0 | 2.10.1 |
| `n8n` | npm | From 2.10.0 | 2.10.1 |

Products: N8n N8n.

## How do I fix CVE-2026-27496?

Upgrade n8n to a fixed version for your release line: 1.123.22, 2.9.3 or 2.10.1.

## Is CVE-2026-27496 being exploited?

There is no known exploitation of CVE-2026-27496 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27496 and fix it if it is affected.

What it is: CVE-2026-27496 is a high-severity vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27496 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.22
- n8n (npm): affected all versions; fixed in 1.123.22
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.9.3
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.9.3
- n8n (npm): affected from 2.10.0; fixed in 2.10.1
- n8n (npm): affected from 2.10.0; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27496/ (Markdown: https://insights.sbomify.com/CVE-2026-27496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27496
- OSV: https://osv.dev/vulnerability/CVE-2026-27496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27496/
Summaries are generated and may contain mistakes; the official description above is the record.
