CVE-2026-27497 n8n has Potential Remote Code Execution via Merge Node
Authenticated users can execute arbitrary code and write files via the Merge node's SQL mode, requiring an upgrade to remediate.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27497?
CVE-2026-27497 is a critical code injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, an authenticated user with permission to create or modify workflows could leverage the Merge node's SQL query mode to execute arbitrary code and write arbitrary files on the n8n server. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Which versions are affected by CVE-2026-27497?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.22 |
n8n npm | All versions | 1.123.22 |
n8n npm | From 2.0.0 | 2.9.3 |
n8n npm | From 2.0.0 | 2.9.3 |
n8n npm | From 2.10.0 | 2.10.1 |
n8n npm | From 2.10.0 | 2.10.1 |
Products include N8n N8n.
How do I fix CVE-2026-27497?
Upgrade n8n to a fixed version for your release line: 1.123.22, 2.9.3 or 2.10.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-27497 being exploited?
There is no known exploitation of CVE-2026-27497 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-wxx7-mcgf-j869.