# CVE-2026-27498: n8n has Arbitrary Command Execution via File Write and Git Operations

> Authenticated users can execute arbitrary shell commands on the host by chaining file write and git operations in n8n workflows.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-x2mw-7j39-93xq

## What is CVE-2026-27498?

CVE-2026-27498 is a critical command injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 2.2.0 and 1.123.8, an authenticated user with permission to create or modify workflows could chain the Read/Write Files from Disk node with git operations to achieve remote code execution. By writing to specific configuration files and then triggering a git operation, the attacker could execute arbitrary shell commands on the n8n host. The issue has been fixed in n8n versions 2.2.0 and 1.123.8. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Read/Write Files from Disk node by adding `n8n-nodes-base.readWriteFile` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-27498?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.8 |
| `n8n` | npm | All versions | 1.123.8 |
| `n8n` | npm | From 2.0.0 | 2.2.0 |
| `n8n` | npm | From 2.0.0 | 2.2.0 |

Products: N8n N8n.

## How do I fix CVE-2026-27498?

Upgrade n8n to a fixed version for your release line: 1.123.8 or 2.2.0.

## Is CVE-2026-27498 being exploited?

There is no known exploitation of CVE-2026-27498 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27498 and fix it if it is affected.

What it is: CVE-2026-27498 is a critical command injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27498 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.8
- n8n (npm): affected all versions; fixed in 1.123.8
- n8n (npm): affected from 2.0.0; fixed in 2.2.0
- n8n (npm): affected from 2.0.0; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27498/ (Markdown: https://insights.sbomify.com/CVE-2026-27498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27498
- OSV: https://osv.dev/vulnerability/CVE-2026-27498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27498/
Summaries are generated and may contain mistakes; the official description above is the record.
