CVE-2026-27570 Discourse Vulnerable to Stored XSS via Shared AI Conversation Onebox

Medium 5.1 Published Updated

Attackers can inject malicious scripts via shared AI conversation titles, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-27570?

CVE-2026-27570 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, the onebox method in the SharedAiConversation model renders the conversation title directly into HTML without proper sanitization. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, tighten access by changing the `ai_bot_public_sharing_allowed_groups` site setting.

Weakness: CWE-79

Which versions are affected by CVE-2026-27570?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiFrom 2026.1.02026.1.2, 2026.2.1, 2026.3.0

Products include Discourse Discourse.

How do I fix CVE-2026-27570?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-27570 being exploited?

There is no known exploitation of CVE-2026-27570 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27570, GHSA-hfxw-89hw-vwmv.

Is CVE-2026-27570 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free