CVE-2026-27571 nats-server websockets are vulnerable to pre-auth memory DoS
Unauthenticated attackers can cause a denial of service via memory exhaustion using WebSocket compression bombs in NATS server deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27571?
CVE-2026-27571 is a medium-severity denial of service vulnerability in nats-io nats-server, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. The WebSockets handling of NATS messages handles compressed messages via the WebSockets negotiated compression. Prior to versions 2.11.2 and 2.12.3, the implementation bound the memory size of a NATS message but did not independently bound the memory consumption of the memory stream when constructing a NATS message which might then fail validation for size reasons. An attacker can use a compression bomb to cause excessive memory consumption, often resulting in the operating system terminating the server process. The use of compression is negotiated before authentication, so this does not require valid NATS credentials to exploit. The fix, present in versions 2.11.2 and 2.12.3, was to bounds the decompression to fail once the message was too large, instead of continuing on. The vulnerability only affects deployments which use WebSockets and which expose the network port to untrusted end-points.
Which versions are affected by CVE-2026-27571?
9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.12, 2.12.3 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.12 |
github.com/nats-io/nats-server/v2 Go | All versions | 2.11.12 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.3 |
github.com/nats-io/nats-server/v2 Go | From 2.12.0-RC.1 | 2.12.3 |
nats Bitnami | All versions | 2.11.12, 2.12.3 |
3 more packages
github.com/nats-io/nats-server Go | All versions | None |
github.com/nats-io/nats-server Go | All versions to 1.4.1 | None |
github.com/nats-io/nats-server Go | All versions to 1.4.1 | None |
Products include Linuxfoundation Nats-Server.
How do I fix CVE-2026-27571?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.12 or 2.12.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-27571 being exploited?
There is no known exploitation of CVE-2026-27571 in the wild and no public exploit code.
Other vulnerabilities in nats-io nats-server
- CVE-2022-28357 NATS nats-server allows directory traversal via unintended path to a management action
- CVE-2026-58253 NATS Server: Route API Auth Bypass
- CVE-2022-24450 Incorrect Authorization in NATS nats-server
- CVE-2026-33216 NATS has MQTT plaintext password disclosure
- CVE-2026-58207 NATS Server: Remote crash via integer overflow in Connz pagination
Sources
Also known as AZL-78372, AZL-78374, BIT-nats-2026-27571, DEBIAN-CVE-2026-27571, ECHO-dd25-4926-4277, GHSA-qrvq-68c2-7grw and 7 more.