# CVE-2026-27571: nats-server websockets are vulnerable to pre-auth memory DoS

> Unauthenticated attackers can cause a denial of service via memory exhaustion using WebSocket compression bombs in NATS server deployments.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-78372, AZL-78374, BIT-nats-2026-27571, DEBIAN-CVE-2026-27571, ECHO-dd25-4926-4277, GHSA-qrvq-68c2-7grw, GO-2026-4533, JLSEC-2026-1120, MINI-6j34-c89h-qjfh, MINI-fffv-35fp-hf37, MINI-jx36-xwvr-6w3p, MINI-pjjw-7367-wvvc, UBUNTU-CVE-2026-27571

## What is CVE-2026-27571?

CVE-2026-27571 is a medium-severity denial of service vulnerability in nats-io nats-server, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. The WebSockets handling of NATS messages handles compressed messages via the WebSockets negotiated compression. Prior to versions 2.11.2 and 2.12.3, the implementation bound the memory size of a NATS message but did not independently bound the memory consumption of the memory stream when constructing a NATS message which might then fail validation for size reasons. An attacker can use a compression bomb to cause excessive memory consumption, often resulting in the operating system terminating the server process. The use of compression is negotiated before authentication, so this does not require valid NATS credentials to exploit. The fix, present in versions 2.11.2 and 2.12.3, was to bounds the decompression to fail once the message was too large, instead of continuing on. The vulnerability only affects deployments which use WebSockets and which expose the network port to untrusted end-points.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-27571?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.12, 2.12.3 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.12 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.12 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.3 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.3 |
| `nats` | Bitnami | All versions | 2.11.12, 2.12.3 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions to 1.4.1 | None |
| `github.com/nats-io/nats-server` | Go | All versions to 1.4.1 | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-27571?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.12 or 2.12.3.

## Is CVE-2026-27571 being exploited?

There is no known exploitation of CVE-2026-27571 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27571 and fix it if it is affected.

What it is: CVE-2026-27571 is a medium-severity denial of service vulnerability in nats-io nats-server, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27571 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.12, 2.12.3
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.12
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.12
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.3
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.3
- nats (Bitnami): affected all versions; fixed in 2.11.12, 2.12.3
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions up to 1.4.1; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions up to 1.4.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27571/ (Markdown: https://insights.sbomify.com/CVE-2026-27571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27571
- OSV: https://osv.dev/vulnerability/CVE-2026-27571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27571/
Summaries are generated and may contain mistakes; the official description above is the record.
