CVE-2026-27576 OpenClaw: ACP prompt-size checks missing in local stdio bridge could reduce responsiveness with very large inputs

Medium 4.8 Published Updated

Local ACP clients sending oversized prompts can degrade OpenClaw responsiveness due to missing size checks, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27576?

CVE-2026-27576 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 21 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw is a personal AI assistant. In versions 2026.2.17 and below, the ACP bridge accepts very large prompt text blocks and can assemble oversized prompt payloads before forwarding them to chat.send. Because ACP runs over local stdio, this mainly affects local ACP clients (for example IDE integrations) that send unusually large inputs. This issue has been fixed in version 2026.2.19.

Weakness: CWE-400

Which versions are affected by CVE-2026-27576?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.19
openclaw npmAll versions2026.2.19

Products include Openclaw Openclaw.

How do I fix CVE-2026-27576?

Upgrade openclaw to 2026.2.19 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-27576 being exploited?

There is no known exploitation of CVE-2026-27576 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-cxpw-2g23-2vgw, MINI-5vp2-wfm2-5rf4.

Is CVE-2026-27576 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free