{"answers":{"affected":"6 open source packages ship an affected version, including n8n. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27577 in the wild and no public exploit code.","fix":"Upgrade n8n to a fixed version for your release line: 1.123.22, 2.9.3 or 2.10.1.","what":"CVE-2026-27577 is a critical code injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27577 and fix it if it is affected.\n\nWhat it is: CVE-2026-27577 is a critical code injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27577 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- n8n (npm): affected all versions; fixed in 1.123.22\n- n8n (npm): affected all versions; fixed in 1.123.22\n- n8n (npm): affected from 2.0.0; fixed in 2.9.3\n- n8n (npm): affected from 2.0.0; fixed in 2.9.3\n- n8n (npm): affected from 2.10.0; fixed in 2.10.1\n- n8n (npm): affected from 2.10.0; fixed in 2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27577/ (Markdown: https://insights.sbomify.com/CVE-2026-27577/index.md)","id":"CVE-2026-27577","markdown":"https://insights.sbomify.com/CVE-2026-27577/index.md","name":"CVE-2026-27577","record":{"aliases":["GHSA-vpcf-gvg4-6qwr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"workflow automation platform","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary system commands via crafted expressions in workflow parameters, requiring an upgrade to remediate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"n8n","vendor":"n8n"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, additional exploits in the expression evaluation of n8n have been identified and patched following CVE-2025-68613. An authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-07-28","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-07-28T02:01:58Z","kind":"github_poc","ref":"https://github.com/HORKimhab/CVE-2026-27577","stars":0,"title":"CVE-2026-27577 - Draft or Todo"}],"tier":"poc_unverified"},"has_fix":true,"headline":"n8n: Expression Sandbox Escape Leads to RCE","id":"CVE-2026-27577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"n8n:n8n","products":["n8n:n8n"],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":5,"next":{"headline":"n8n Vulnerable to Stored XSS via Various Nodes","id":"CVE-2026-27578"},"packages":[{"ecosystem":"npm","fixed":["1.123.22"],"introduced":["0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-vpcf-gvg4-6qwr"},{"ecosystem":"npm","fixed":["1.123.22"],"introduced":["0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-vpcf-gvg4-6qwr"},{"ecosystem":"npm","fixed":["2.9.3"],"introduced":["2.0.0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-vpcf-gvg4-6qwr"},{"ecosystem":"npm","fixed":["2.9.3"],"introduced":["2.0.0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-vpcf-gvg4-6qwr"},{"ecosystem":"npm","fixed":["2.10.1"],"introduced":["2.10.0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-vpcf-gvg4-6qwr"},{"ecosystem":"npm","fixed":["2.10.1"],"introduced":["2.10.0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-vpcf-gvg4-6qwr"}],"prev":{"headline":"OpenClaw: ACP prompt-size checks missing in local stdio bridge could reduce responsiveness with very large inputs","id":"CVE-2026-27576"},"products":["n8n"],"published":"2026-02-25","related":[{"cvss_score":10,"headline":"n8n Improper Control of Dynamically-Managed Code Resources","id":"CVE-2025-68613","kev_date_added":"2026-03-11","published":"2025-12-19"},{"cvss_score":10,"headline":"n8n is vulnerable to Remote Code Execution via Arbitrary File Write","id":"CVE-2026-21877","kev_date_added":null,"published":"2026-01-08"},{"cvss_score":10,"headline":"n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling","id":"CVE-2026-21858","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":9.9,"headline":"n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution","id":"CVE-2026-1470","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":9.9,"headline":"n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node","id":"CVE-2025-68668","kev_date_added":null,"published":"2025-12-26"},{"cvss_score":9.5,"headline":"n8n has Unauthenticated Expression Evaluation via Form Node","id":"CVE-2026-27493","kev_date_added":null,"published":"2026-02-25"},{"cvss_score":9.4,"headline":"n8n: HTTP Request Node Pagination Prototype Pollution to RCE","id":"CVE-2026-44789","kev_date_added":null,"published":"2026-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["n8n-io"]},"summary":"Authenticated users can execute arbitrary system commands via crafted expressions in workflow parameters, requiring an upgrade to remediate.","url":"https://insights.sbomify.com/CVE-2026-27577/"}