# CVE-2026-27577: n8n: Expression Sandbox Escape Leads to RCE

> Authenticated users can execute arbitrary system commands via crafted expressions in workflow parameters, requiring an upgrade to remediate.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-vpcf-gvg4-6qwr

## What is CVE-2026-27577?

CVE-2026-27577 is a critical code injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 2.10.1, 2.9.3, and 1.123.22, additional exploits in the expression evaluation of n8n have been identified and patched following CVE-2025-68613. An authenticated user with permission to create or modify workflows could abuse crafted expressions in workflow parameters to trigger unintended system command execution on the host running n8n. The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate all known vulnerabilities. If upgrading is not immediately possible, administrators should consider the following temporary mitigations. Limit workflow creation and editing permissions to fully trusted users only, and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-27577?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.22 |
| `n8n` | npm | All versions | 1.123.22 |
| `n8n` | npm | From 2.0.0 | 2.9.3 |
| `n8n` | npm | From 2.0.0 | 2.9.3 |
| `n8n` | npm | From 2.10.0 | 2.10.1 |
| `n8n` | npm | From 2.10.0 | 2.10.1 |

Products: N8n N8n.

## How do I fix CVE-2026-27577?

Upgrade n8n to a fixed version for your release line: 1.123.22, 2.9.3 or 2.10.1.

## Is CVE-2026-27577 being exploited?

There is no known exploitation of CVE-2026-27577 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-27577 - Draft or Todo (github_poc): https://github.com/HORKimhab/CVE-2026-27577

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27577 and fix it if it is affected.

What it is: CVE-2026-27577 is a critical code injection vulnerability in N8n N8n, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27577 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.22
- n8n (npm): affected all versions; fixed in 1.123.22
- n8n (npm): affected from 2.0.0; fixed in 2.9.3
- n8n (npm): affected from 2.0.0; fixed in 2.9.3
- n8n (npm): affected from 2.10.0; fixed in 2.10.1
- n8n (npm): affected from 2.10.0; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27577/ (Markdown: https://insights.sbomify.com/CVE-2026-27577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27577
- OSV: https://osv.dev/vulnerability/CVE-2026-27577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27577/
Summaries are generated and may contain mistakes; the official description above is the record.
