# CVE-2026-27587: Caddy: MatchPath %xx (escaped-path) branch skips case normalization, enabling path-based route/auth bypass

> Attackers can bypass path-based routing and access controls in Caddy by manipulating case in percent-encoded paths.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-27587, GHSA-g7pc-pc7g-h8jh, GO-2026-4538, MINI-qpp3-fxrg-82v7, UBUNTU-CVE-2026-27587

## What is CVE-2026-27587?

CVE-2026-27587 is a high-severity vulnerability in caddyserver caddy, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, Caddy's HTTP `path` request matcher is intended to be case-insensitive, but when the match pattern contains percent-escape sequences (`%xx`) it compares against the request's escaped path without lowercasing. An attacker can bypass path-based routing and any access controls attached to that route by changing the casing of the request path. Version 2.11.1 contains a fix for the issue.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-27587?

3 open source packages ship an affected version, including github.com/caddyserver/caddy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.1 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.1 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.11.1 |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-27587?

Upgrade github.com/caddyserver/caddy/v2 to 2.11.1 or later.

## Is CVE-2026-27587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27587 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27587 and fix it if it is affected.

What it is: CVE-2026-27587 is a high-severity vulnerability in caddyserver caddy, published on 24 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27587 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.1
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.1
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27587/ (Markdown: https://insights.sbomify.com/CVE-2026-27587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27587
- OSV: https://osv.dev/vulnerability/CVE-2026-27587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27587/
Summaries are generated and may contain mistakes; the official description above is the record.
