# CVE-2026-27591: Winter: Privilege escalation by authenticated backend users

> Authenticated backend users can escalate privileges by modifying their own roles and permissions via crafted requests.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-pgpf-m8m4-6cg6

## What is CVE-2026-27591?

CVE-2026-27591 is a critical vulnerability in wintercms winter, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Winter is a free, open-source content management system (CMS) based on the Laravel PHP framework. Prior to 1.0.477, 1.1.12, and 1.2.12, Winter CMS allowed authenticated backend users to escalate their accounts level of access to the system by modifying the roles / permissions assigned to their account through specially crafted requests to the backend while logged in. To actively exploit this security issue, an attacker would need access to the Backend with a user account with any level of access. This vulnerability is fixed in 1.0.477, 1.1.12, and 1.2.12.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-27591?

6 open source packages ship an affected version, including winter/wn-backend-module. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `winter/wn-backend-module` | Packagist | All versions | 1.0.477 |
| `winter/wn-backend-module` | Packagist | All versions | 1.0.477 |
| `winter/wn-backend-module` | Packagist | From 1.1.0 | 1.1.12 |
| `winter/wn-backend-module` | Packagist | From 1.1.0 | 1.1.12 |
| `winter/wn-backend-module` | Packagist | From 1.2.0 | 1.2.12 |
| `winter/wn-backend-module` | Packagist | From 1.2.0 | 1.2.12 |

Products: Wintercms Winter.

## How do I fix CVE-2026-27591?

Upgrade winter/wn-backend-module to a fixed version for your release line: 1.0.477, 1.1.12 or 1.2.12.

## Is CVE-2026-27591 being exploited?

There is no known exploitation of CVE-2026-27591 in the wild and no public exploit code.

## Other vulnerabilities in wintercms winter

- [CVE-2024-54149](https://insights.sbomify.com/CVE-2024-54149/): Winter CMS Modules allows a sandbox bypass in Twig templates leading to data modification and deletion (high 8.5)
- [CVE-2022-39357](https://insights.sbomify.com/CVE-2022-39357/): Winter vulnerable to Prototype Pollution in Snowboard framework (high 8.1)
- [CVE-2024-29686](https://insights.sbomify.com/CVE-2024-29686/): Winter CMS Server-Side Template Injection (SSTI) vulnerability (high 7.2)
- [CVE-2023-52085](https://insights.sbomify.com/CVE-2023-52085/): Winter CMS Local File Inclusion through Server Side Template Injection (low 3.3)
- [CVE-2023-52083](https://insights.sbomify.com/CVE-2023-52083/): Stored XSS through privileged upload of Media Manager file followed by renaming (low 2.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27591 and fix it if it is affected.

What it is: CVE-2026-27591 is a critical vulnerability in wintercms winter, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27591 in the wild and no public exploit code.

Affected packages and fixed versions:
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.0.477
- winter/wn-backend-module (Packagist): affected all versions; fixed in 1.0.477
- winter/wn-backend-module (Packagist): affected from 1.1.0; fixed in 1.1.12
- winter/wn-backend-module (Packagist): affected from 1.1.0; fixed in 1.1.12
- winter/wn-backend-module (Packagist): affected from 1.2.0; fixed in 1.2.12
- winter/wn-backend-module (Packagist): affected from 1.2.0; fixed in 1.2.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27591/ (Markdown: https://insights.sbomify.com/CVE-2026-27591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27591
- OSV: https://osv.dev/vulnerability/CVE-2026-27591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27591/
Summaries are generated and may contain mistakes; the official description above is the record.
