# CVE-2026-27596: Exiv2: Integer Underflow in LoaderNative::getData() Causes Heap Buffer Overflow

> An integer underflow in Exiv2 causes a heap buffer overflow and crash when processing preview images with specific command-line arguments.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2026
- **Updated:** 2 Mar 2026
- **Also known as:** AZL-78521, AZL-78624, DEBIAN-CVE-2026-27596, GHSA-3wgv-fg4w-75x7, JLSEC-2026-1317

## What is CVE-2026-27596?

CVE-2026-27596 is a low-severity vulnerability in Exiv2 Exiv2, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Exiv2 is a C++ library and a command-line utility to read, write, delete and modify Exif, IPTC, XMP and ICC image metadata. Prior to version 0.28.8, an out-of-bounds read was found in Exiv2. The vulnerability is in the preview component, which is only triggered when running Exiv2 with an extra command line argument, like -pp. The out-of-bounds read is at a 4GB offset, which usually causes Exiv2 to crash. This issue has been patched in version 0.28.8.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound)), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-27596?

It affects 1 product.


Products: Exiv2 Exiv2.

## How do I fix CVE-2026-27596?

Upgrade to a fixed version.

## Is CVE-2026-27596 being exploited?

There is no known exploitation of CVE-2026-27596 in the wild and no public exploit code.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27596 and fix it if it is affected.

What it is: CVE-2026-27596 is a low-severity vulnerability in Exiv2 Exiv2, published on 2 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27596 in the wild and no public exploit code.

Affected product: Exiv2 Exiv2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27596/ (Markdown: https://insights.sbomify.com/CVE-2026-27596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27596
- OSV: https://osv.dev/vulnerability/CVE-2026-27596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27596/
Summaries are generated and may contain mistakes; the official description above is the record.
