CVE-2026-27601 Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack
An attacker can cause a Denial of Service via stack overflow in Underscore.js by passing deeply nested untrusted data to specific functions without depth limits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27601?
CVE-2026-27601 is a high-severity denial of service vulnerability in jashkenas underscore, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.
Weakness: CWE-770
Which versions are affected by CVE-2026-27601?
2 open source packages ship an affected version, including underscore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
underscore npm | All versions | 1.13.8 |
underscore npm | All versions | 1.13.8 |
Linux distribution packages (2)
python-ipympl openSUSE:Tumbleweed | All versions | 0.9.7-17.1 |
python-nbclassic openSUSE:Tumbleweed | All versions | 1.3.3-1.1 |
Products include Underscorejs Underscore.
How do I fix CVE-2026-27601?
Upgrade underscore to 1.13.8 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-27601 being exploited?
There is no known exploitation of CVE-2026-27601 in the wild and no public exploit code.
Sources
Also known as AZL-79313, AZL-79320, AZL-79323, AZL-79340, AZL-79343, AZL-79397 and 21 more.