{"answers":{"affected":"2 open source packages ship an affected version, including underscore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27601 in the wild and no public exploit code.","fix":"Upgrade underscore to 1.13.8 or later.","what":"CVE-2026-27601 is a high-severity denial of service vulnerability in jashkenas underscore, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27601 and fix it if it is affected.\n\nWhat it is: CVE-2026-27601 is a high-severity denial of service vulnerability in jashkenas underscore, published on 3 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27601 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- underscore (npm): affected all versions; fixed in 1.13.8\n- underscore (npm): affected all versions; fixed in 1.13.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27601/ (Markdown: https://insights.sbomify.com/CVE-2026-27601/index.md)","id":"CVE-2026-27601","markdown":"https://insights.sbomify.com/CVE-2026-27601/index.md","name":"CVE-2026-27601","record":{"aliases":["AZL-79313","AZL-79320","AZL-79323","AZL-79340","AZL-79343","AZL-79397","AZL-79401","AZL-79404","AZL-79427","AZL-79434","AZL-79463","CLEANSTART-2026-XN28189","CLEANSTART-2026-ZP55768","CLSA-2026-1792767555","DEBIAN-CVE-2026-27601","ECHO-0638-253e-d3ec","GHSA-qpx9-hpmf-5gmw","MINI-p855-9chv-j5f4","OESA-2026-1578","OESA-2026-1579","OESA-2026-1580","OESA-2026-1581","ROOT-APP-NPM-CVE-2026-27601","ROOT-OS-DEBIAN-12-CVE-2026-27601","UBUNTU-CVE-2026-27601","openSUSE-SU-2026:10427-1","openSUSE-SU-2026:10440-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript utility library","requires_auth":"none","summary":"An attacker can cause a Denial of Service via stack overflow in Underscore.js by passing deeply nested untrusted data to specific functions without depth limits.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"underscore","vendor":"underscorejs"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack","id":"CVE-2026-27601","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Modoboa has an OS Command Injection","id":"CVE-2026-27602"},"packages":[{"ecosystem":"npm","fixed":["1.13.8"],"introduced":["0"],"last_affected":[],"package":"underscore","purl":null,"source":"GHSA-qpx9-hpmf-5gmw"},{"ecosystem":"npm","fixed":["1.13.8"],"introduced":["0"],"last_affected":[],"package":"underscore","purl":"pkg:npm/underscore","source":"GHSA-qpx9-hpmf-5gmw"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9.7-17.1"],"introduced":["0"],"last_affected":[],"package":"python-ipympl","purl":"pkg:rpm/opensuse/python-ipympl\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10427-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.3.3-1.1"],"introduced":["0"],"last_affected":[],"package":"python-nbclassic","purl":"pkg:rpm/opensuse/python-nbclassic\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10440-1"}],"prev":{"headline":"HomeBox affected by Blind SSRF","id":"CVE-2026-27600"},"products":["underscore"],"published":"2026-03-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-04","vendors":["jashkenas"]},"summary":"An attacker can cause a Denial of Service via stack overflow in Underscore.js by passing deeply nested untrusted data to specific functions without depth limits.","url":"https://insights.sbomify.com/CVE-2026-27601/"}