# CVE-2026-27602: Modoboa has an OS Command Injection

> Attackers with Reseller or SuperAdmin privileges can execute arbitrary OS commands by injecting shell metacharacters into domain names.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 26 Mar 2026
- **Also known as:** GHSA-wwv8-cqpr-vx3m, PYSEC-2026-2223

## What is CVE-2026-27602?

CVE-2026-27602 is a high-severity command injection vulnerability in modoboa, published on 25 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Modoboa is a mail hosting and management platform. Prior to version 2.7.1, `exec_cmd()` in `modoboa/lib/sysutils.py` always runs subprocess calls with `shell=True`. Since domain names flow directly into shell command strings without any sanitization, a Reseller or SuperAdmin can include shell metacharacters in a domain name to run arbitrary OS commands on the server. Version 2.7.1 patches the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-27602?

3 open source packages ship an affected version, including modoboa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modoboa` | PyPI | All versions | 2.7.1 |
| `modoboa` | PyPI | All versions | 2.7.1 |
| `modoboa` | PyPI | All versions | 2.7.1 |

Products: Modoboa Modoboa.

## How do I fix CVE-2026-27602?

Upgrade modoboa to 2.7.1 or later.

## Is CVE-2026-27602 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27602 exists.

## Other vulnerabilities in modoboa

- [CVE-2023-5688](https://insights.sbomify.com/CVE-2023-5688/): Cross-site Scripting (XSS) - DOM in modoboa/modoboa (critical 9.8)
- [CVE-2023-2227](https://insights.sbomify.com/CVE-2023-2227/): Improper Authorization in modoboa/modoboa (critical 9.1)
- [CVE-2023-0777](https://insights.sbomify.com/CVE-2023-0777/): Authentication Bypass by Primary Weakness in modoboa/modoboa (high 8.6)
- [CVE-2023-5689](https://insights.sbomify.com/CVE-2023-5689/): Cross-site Scripting (XSS) - DOM in modoboa/modoboa (high 7.1)
- [CVE-2023-0470](https://insights.sbomify.com/CVE-2023-0470/): Cross-site Scripting (XSS) - Stored in modoboa/modoboa (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27602 and fix it if it is affected.

What it is: CVE-2026-27602 is a high-severity command injection vulnerability in modoboa, published on 25 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27602 exists.

Affected packages and fixed versions:
- modoboa (PyPI): affected all versions; fixed in 2.7.1
- modoboa (PyPI): affected all versions; fixed in 2.7.1
- modoboa (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27602/ (Markdown: https://insights.sbomify.com/CVE-2026-27602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27602
- OSV: https://osv.dev/vulnerability/CVE-2026-27602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27602/
Summaries are generated and may contain mistakes; the official description above is the record.
