{"answers":{"affected":"6 open source packages ship an affected version, including rollup. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27606 exists.","fix":"Upgrade rollup to a fixed version for your release line: 2.80.0, 3.30.0 or 4.59.0.","what":"CVE-2026-27606 is a high-severity path traversal vulnerability in rollup, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27606 and fix it if it is affected.\n\nWhat it is: CVE-2026-27606 is a high-severity path traversal vulnerability in rollup, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27606 exists.\n\nAffected packages and fixed versions:\n- rollup (npm): affected all versions; fixed in 2.80.0\n- rollup (npm): affected all versions; fixed in 2.80.0\n- rollup (npm): affected from 3.0.0; fixed in 3.30.0\n- rollup (npm): affected from 3.0.0; fixed in 3.30.0\n- rollup (npm): affected from 4.0.0; fixed in 4.59.0\n- rollup (npm): affected from 4.0.0; fixed in 4.59.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27606/ (Markdown: https://insights.sbomify.com/CVE-2026-27606/index.md)","id":"CVE-2026-27606","markdown":"https://insights.sbomify.com/CVE-2026-27606/index.md","name":"CVE-2026-27606","record":{"aliases":["CLSA-2026-1775176078","CLSA-2026-1775521840","CLSA-2026-1775521842","CLSA-2026-1784596332","CLSA-2026-1792160912","CLSA-2026-1792161062","CLSA-2026-1792161063","CLSA-2026-1792161064","CLSA-2026-1792161065","CLSA-2026-1792161066","CLSA-2026-1792161067","CLSA-2026-1792161068","CLSA-2026-1792161072","CLSA-2026-1792161073","CLSA-2026-1792161074","CLSA-2026-1792161075","CLSA-2026-1792161076","CLSA-2026-1792161077","CLSA-2026-1792161079","CLSA-2026-1793009952","DEBIAN-CVE-2026-27606","GHSA-mw96-cpmx-2vgc","MINI-5vgw-5pgm-354v","MINI-6vwh-4jh4-32qr","MINI-858c-3xg5-prww","MINI-m38m-w7r6-2463","ROOT-APP-NPM-CVE-2026-27606","UBUNTU-CVE-2026-27606","openSUSE-SU-2026:10263-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript module bundler","requires_auth":"none","summary":"Attackers can overwrite arbitrary files via path traversal in Rollup, potentially leading to persistent remote code execution on the host system.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rollup","vendor":"rollupjs"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Rollup is a module bundler for JavaScript. Versions prior to 2.80.0, 3.30.0, and 4.59.0 of the Rollup module bundler (specifically v4.x and present in current source) is vulnerable to an Arbitrary File Write via Path Traversal. Insecure file name sanitization in the core engine allows an attacker to control output filenames (e.g., via CLI named inputs, manual chunk aliases, or malicious plugins) and use traversal sequences (`../`) to overwrite files anywhere on the host filesystem that the build process has permissions for. This can lead to persistent Remote Code Execution (RCE) by overwriting critical system or user configuration files. Versions 2.80.0, 3.30.0, and 4.59.0 contain a patch for the issue.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2026-10-11","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-11T20:09:35Z","kind":"github_poc","ref":"https://github.com/AaaronP/Seguridad---Proyecto-de-investigaci-n","stars":0,"title":"Replicación vulnerabilidad CVE-2026-27606"}],"tier":"weaponised"},"has_fix":true,"headline":"Rollup 4 has Arbitrary File Write via Path Traversal","id":"CVE-2026-27606","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":7,"n_references":7,"next":{"headline":"RustFS's Missing Post Policy Validation leads to Arbitrary Object Write","id":"CVE-2026-27607"},"packages":[{"ecosystem":"npm","fixed":["2.80.0"],"introduced":["0"],"last_affected":[],"package":"rollup","purl":null,"source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"npm","fixed":["2.80.0"],"introduced":["0"],"last_affected":[],"package":"rollup","purl":"pkg:npm/rollup","source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"npm","fixed":["3.30.0"],"introduced":["3.0.0"],"last_affected":[],"package":"rollup","purl":null,"source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"npm","fixed":["3.30.0"],"introduced":["3.0.0"],"last_affected":[],"package":"rollup","purl":"pkg:npm/rollup","source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"npm","fixed":["4.59.0"],"introduced":["4.0.0"],"last_affected":[],"package":"rollup","purl":null,"source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"npm","fixed":["4.59.0"],"introduced":["4.0.0"],"last_affected":[],"package":"rollup","purl":"pkg:npm/rollup","source":"GHSA-mw96-cpmx-2vgc"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.20.0-2.1"],"introduced":["0"],"last_affected":[],"package":"heroic-games-launcher","purl":"pkg:rpm/opensuse/heroic-games-launcher\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10263-1"}],"prev":{"headline":"Chartbrew: Stored Cross-Site Scripting (XSS) via File Upload API","id":"CVE-2026-27605"},"products":["rollup"],"published":"2026-02-25","related":[{"cvss_score":6.1,"headline":"DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS","id":"CVE-2024-47068","kev_date_added":null,"published":"2024-09-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["rollup"]},"summary":"Attackers can overwrite arbitrary files via path traversal in Rollup, potentially leading to persistent remote code execution on the host system.","url":"https://insights.sbomify.com/CVE-2026-27606/"}