# CVE-2026-27606: Rollup 4 has Arbitrary File Write via Path Traversal

> Attackers can overwrite arbitrary files via path traversal in Rollup, potentially leading to persistent remote code execution on the host system.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLSA-2026-1775176078, CLSA-2026-1775521840, CLSA-2026-1775521842, CLSA-2026-1784596332, CLSA-2026-1792160912, CLSA-2026-1792161062, CLSA-2026-1792161063, CLSA-2026-1792161064, CLSA-2026-1792161065, CLSA-2026-1792161066, CLSA-2026-1792161067, CLSA-2026-1792161068, CLSA-2026-1792161072, CLSA-2026-1792161073, CLSA-2026-1792161074, CLSA-2026-1792161075, CLSA-2026-1792161076, CLSA-2026-1792161077, CLSA-2026-1792161079, CLSA-2026-1793009952, DEBIAN-CVE-2026-27606, GHSA-mw96-cpmx-2vgc, MINI-5vgw-5pgm-354v, MINI-6vwh-4jh4-32qr, MINI-858c-3xg5-prww, MINI-m38m-w7r6-2463, ROOT-APP-NPM-CVE-2026-27606, UBUNTU-CVE-2026-27606, openSUSE-SU-2026:10263-1

## What is CVE-2026-27606?

CVE-2026-27606 is a high-severity path traversal vulnerability in rollup, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rollup is a module bundler for JavaScript. Versions prior to 2.80.0, 3.30.0, and 4.59.0 of the Rollup module bundler (specifically v4.x and present in current source) is vulnerable to an Arbitrary File Write via Path Traversal. Insecure file name sanitization in the core engine allows an attacker to control output filenames (e.g., via CLI named inputs, manual chunk aliases, or malicious plugins) and use traversal sequences (`../`) to overwrite files anywhere on the host filesystem that the build process has permissions for. This can lead to persistent Remote Code Execution (RCE) by overwriting critical system or user configuration files. Versions 2.80.0, 3.30.0, and 4.59.0 contain a patch for the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-27606?

6 open source packages ship an affected version, including rollup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rollup` | npm | All versions | 2.80.0 |
| `rollup` | npm | All versions | 2.80.0 |
| `rollup` | npm | From 3.0.0 | 3.30.0 |
| `rollup` | npm | From 3.0.0 | 3.30.0 |
| `rollup` | npm | From 4.0.0 | 4.59.0 |
| `rollup` | npm | From 4.0.0 | 4.59.0 |
| `heroic-games-launcher` | openSUSE:Tumbleweed | All versions | 2.20.0-2.1 |

Products: Rollupjs Rollup.

## How do I fix CVE-2026-27606?

Upgrade rollup to a fixed version for your release line: 2.80.0, 3.30.0 or 4.59.0.

## Is CVE-2026-27606 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27606 exists.

Public exploit code:

- Replicación vulnerabilidad CVE-2026-27606 (github_poc): https://github.com/AaaronP/Seguridad---Proyecto-de-investigaci-n

## Other vulnerabilities in rollup

- [CVE-2024-47068](https://insights.sbomify.com/CVE-2024-47068/): DOM Clobbering Gadget found in rollup bundled scripts that leads to XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27606 and fix it if it is affected.

What it is: CVE-2026-27606 is a high-severity path traversal vulnerability in rollup, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27606 exists.

Affected packages and fixed versions:
- rollup (npm): affected all versions; fixed in 2.80.0
- rollup (npm): affected all versions; fixed in 2.80.0
- rollup (npm): affected from 3.0.0; fixed in 3.30.0
- rollup (npm): affected from 3.0.0; fixed in 3.30.0
- rollup (npm): affected from 4.0.0; fixed in 4.59.0
- rollup (npm): affected from 4.0.0; fixed in 4.59.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27606/ (Markdown: https://insights.sbomify.com/CVE-2026-27606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27606
- OSV: https://osv.dev/vulnerability/CVE-2026-27606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27606/
Summaries are generated and may contain mistakes; the official description above is the record.
