# CVE-2026-27614: Bugsink is vulnerable to Stored XSS via Pygments fallback in stacktrace rendering

> An unauthenticated attacker can inject JavaScript into error events, which executes in an administrator's browser when viewed, allowing privilege escalation.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-vp6q-7m36-pq3w, PYSEC-2026-301

## What is CVE-2026-27614?

CVE-2026-27614 is a critical cross-site scripting vulnerability in bugsink, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Bugsink is a self-hosted error tracking tool. In versions prior to 2.0.13, an unauthenticated attacker who can submit events to a Bugsink project can store arbitrary JavaScript in an event. The payload executes only if a user explicitly views the affected Stacktrace in the web UI. When Pygments returns more lines than it was given (a known upstream quirk that triggers with Ruby heredoc-style input), `_pygmentize_lines()` in `theme/templatetags/issues.py:75-77` falls back to returning the raw input lines. `mark_safe()` at line 111-113 is then applied unconditionally - including to those unsanitized raw lines. Since DSN endpoints are public by Sentry protocol, no account is needed to inject. The payload sits in the database until an admin looks at the event. Successful exploitation requires that the attacker to be able to submit events to the project (i.e. knows the DSN or can access a client that uses it), the Bugsink ingest endpoint is reachable to the attacker, and an administrator explicitly views the crafted event in the UI. Under those conditions, the attacker can execute JavaScript in the administrator’s browser and act with that user’s privileges within Bugsink. Version 2.0.13 fixes the vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27614?

3 open source packages ship an affected version, including bugsink. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 2.0.13 |
| `bugsink` | PyPI | All versions | 2.0.13 |
| `bugsink` | PyPI | All versions | 2.0.13 |

Products: Bugsink Bugsink.

## How do I fix CVE-2026-27614?

Upgrade bugsink to 2.0.13 or later.

## Is CVE-2026-27614 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27614 exists.

## Other vulnerabilities in bugsink

- [CVE-2026-40162](https://insights.sbomify.com/CVE-2026-40162/): Bugsink affected by authenticated arbitrary file write in artifactbundle/assemble (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27614 and fix it if it is affected.

What it is: CVE-2026-27614 is a critical cross-site scripting vulnerability in bugsink, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27614 exists.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 2.0.13
- bugsink (PyPI): affected all versions; fixed in 2.0.13
- bugsink (PyPI): affected all versions; fixed in 2.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27614/ (Markdown: https://insights.sbomify.com/CVE-2026-27614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27614
- OSV: https://osv.dev/vulnerability/CVE-2026-27614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27614/
Summaries are generated and may contain mistakes; the official description above is the record.
