CVE-2026-27621 TypiCMS Core has Stored Cross-Site Scripting (XSS) via SVG File Upload
Attackers can upload malicious SVG files to execute scripts in other users' browsers, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27621?
CVE-2026-27621 is a medium-severity cross-site scripting vulnerability in TypiCMS Core, published on 25 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TypiCMS is a multilingual content management system based on the Laravel framework. A Stored Cross-Site Scripting (XSS) vulnerability exists in the file upload module of TypiCMS prior to version 16.1.7. The application allows users with file upload permissions to upload SVG files. While there is a MIME type validation, the content of the SVG file is not sanitized. An attacker can upload a specially crafted SVG file containing malicious JavaScript code. When another user (such as an administrator) views or accesses this file through the application, the script executes in their browser, leading to a compromise of that user's session. The issue is exacerbated by a bug in the SVG parsing logic, which can cause a 500 error if the uploaded SVG does not contain a `viewBox` attribute. However, this does not mitigate the XSS vulnerability, as an attacker can easily include a valid `viewBox` attribute in their malicious payload. Version 16.1.7 of TypiCMS Core fixes the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-27621?
10 open source packages ship an affected version, including typicms/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typicms/core Packagist | All versions | 12.0.5 |
typicms/core Packagist | All versions | 12.0.5 |
typicms/core Packagist | From 13.0.0 | 13.0.9 |
typicms/core Packagist | From 13.0.0 | 13.0.9 |
typicms/core Packagist | From 14.0.0 | 14.0.27 |
typicms/core Packagist | From 14.0.0 | 14.0.27 |
4 more packages
typicms/core Packagist | From 15.0.0 | 15.0.29 |
typicms/core Packagist | From 15.0.0 | 15.0.29 |
typicms/core Packagist | From 16.0.0 | 16.1.7 |
typicms/core Packagist | From 16.0.0 | 16.1.7 |
Products include Typicms Typicms.
How do I fix CVE-2026-27621?
Upgrade typicms/core to a fixed version for your release line: 12.0.5, 13.0.9, 14.0.27 or 15.0.29.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-27621 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27621 exists.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as GHSA-xfvg-8v67-j7wp.