# CVE-2026-27621: TypiCMS Core has Stored Cross-Site Scripting (XSS) via SVG File Upload

> Attackers can upload malicious SVG files to execute scripts in other users' browsers, potentially leading to session hijacking.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-xfvg-8v67-j7wp

## What is CVE-2026-27621?

CVE-2026-27621 is a medium-severity cross-site scripting vulnerability in TypiCMS Core, published on 25 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

TypiCMS is a multilingual content management system based on the Laravel framework. A Stored Cross-Site Scripting (XSS) vulnerability exists in the file upload module of TypiCMS prior to version 16.1.7. The application allows users with file upload permissions to upload SVG files. While there is a MIME type validation, the content of the SVG file is not sanitized. An attacker can upload a specially crafted SVG file containing malicious JavaScript code. When another user (such as an administrator) views or accesses this file through the application, the script executes in their browser, leading to a compromise of that user's session. The issue is exacerbated by a bug in the SVG parsing logic, which can cause a 500 error if the uploaded SVG does not contain a `viewBox` attribute. However, this does not mitigate the XSS vulnerability, as an attacker can easily include a valid `viewBox` attribute in their malicious payload. Version 16.1.7 of TypiCMS Core fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27621?

10 open source packages ship an affected version, including typicms/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typicms/core` | Packagist | All versions | 12.0.5 |
| `typicms/core` | Packagist | All versions | 12.0.5 |
| `typicms/core` | Packagist | From 13.0.0 | 13.0.9 |
| `typicms/core` | Packagist | From 13.0.0 | 13.0.9 |
| `typicms/core` | Packagist | From 14.0.0 | 14.0.27 |
| `typicms/core` | Packagist | From 14.0.0 | 14.0.27 |
| `typicms/core` | Packagist | From 15.0.0 | 15.0.29 |
| `typicms/core` | Packagist | From 15.0.0 | 15.0.29 |
| `typicms/core` | Packagist | From 16.0.0 | 16.1.7 |
| `typicms/core` | Packagist | From 16.0.0 | 16.1.7 |

Products: Typicms Typicms.

## How do I fix CVE-2026-27621?

Upgrade typicms/core to a fixed version for your release line: 12.0.5, 13.0.9, 14.0.27 or 15.0.29.

## Is CVE-2026-27621 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27621 exists.

Public exploit code:

- CVE-2026-27621 - TypiCMS Core has Stored Cross-Site Scripting (XSS) via SVG File Upload (github_poc): https://github.com/lukasz-rybak/CVE-2026-27621

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27621 and fix it if it is affected.

What it is: CVE-2026-27621 is a medium-severity cross-site scripting vulnerability in TypiCMS Core, published on 25 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27621 exists.

Affected packages and fixed versions:
- typicms/core (Packagist): affected all versions; fixed in 12.0.5
- typicms/core (Packagist): affected all versions; fixed in 12.0.5
- typicms/core (Packagist): affected from 13.0.0; fixed in 13.0.9
- typicms/core (Packagist): affected from 13.0.0; fixed in 13.0.9
- typicms/core (Packagist): affected from 14.0.0; fixed in 14.0.27
- typicms/core (Packagist): affected from 14.0.0; fixed in 14.0.27
- typicms/core (Packagist): affected from 15.0.0; fixed in 15.0.29
- typicms/core (Packagist): affected from 15.0.0; fixed in 15.0.29
- typicms/core (Packagist): affected from 16.0.0; fixed in 16.1.7
- typicms/core (Packagist): affected from 16.0.0; fixed in 16.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27621/ (Markdown: https://insights.sbomify.com/CVE-2026-27621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27621
- OSV: https://osv.dev/vulnerability/CVE-2026-27621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27621/
Summaries are generated and may contain mistakes; the official description above is the record.
