# CVE-2026-27623: Valkey has Pre-Authentication DOS from malformed RESP request


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-27623, BIT-valkey-2026-27623, GHSA-93p9-5vc7-8wgr

## What is CVE-2026-27623?

CVE-2026-27623 is a high-severity vulnerability in valkey-io valkey, published on 23 Feb 2026. 

### Official description

Valkey is a distributed key-value database. Starting in version 9.0.0 and prior to version 9.0.3, a malicious actor with network access to Valkey can cause the system to abort by triggering an assertion. When processing incoming requests, the Valkey system does not properly reset the networking state after processing an empty request. A malicious actor can then send a request that the server incorrectly identifies as breaking server side invariants, which results in the server shutting down. Version 9.0.3 fixes the issue. As an additional mitigation, properly isolate Valkey deployments so that only trusted users have access.

Weakness: CWE-617 (Reachable Assertion), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-27623?

1 open source package ship an affected version, including valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `valkey` | Bitnami | From 9.0.0 | 9.0.3 |

Products: Lfprojects Valkey.

## How do I fix CVE-2026-27623?

Upgrade valkey to 9.0.3 or later.

## Is CVE-2026-27623 being exploited?

There is no known exploitation of CVE-2026-27623 in the wild and no public exploit code.

## Other vulnerabilities in valkey-io valkey

- [CVE-2025-49844](https://insights.sbomify.com/CVE-2025-49844/): Redis Lua Use-After-Free may lead to remote code execution (critical 10.0)
- [CVE-2025-67733](https://insights.sbomify.com/CVE-2025-67733/): Valkey Affected by RESP Protocol Injection via Lua error_reply (high 8.5)
- [CVE-2026-21863](https://insights.sbomify.com/CVE-2026-21863/): Malformed Valkey Cluster bus message can lead to Remote DoS (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27623 and fix it if it is affected.

What it is: CVE-2026-27623 is a high-severity vulnerability in valkey-io valkey, published on 23 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-27623 in the wild and no public exploit code.

Affected packages and fixed versions:
- valkey (Bitnami): affected from 9.0.0; fixed in 9.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27623/ (Markdown: https://insights.sbomify.com/CVE-2026-27623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27623
- OSV: https://osv.dev/vulnerability/CVE-2026-27623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27623/
Summaries are generated and may contain mistakes; the official description above is the record.
