CVE-2026-27656 Account Takeover via Substring Matching in OpenID Connect Authentication
Attackers can take over arbitrary user accounts due to flawed substring matching in OpenID Connect authentication logic.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27656?
CVE-2026-27656 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 25 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow.. Mattermost Advisory ID: MMSA-2026-00590
Weakness: CWE-303
Which versions are affected by CVE-2026-27656?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.12 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1 | 10.11.12 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.4 |
github.com/mattermost/mattermost-server Go | From 11.2.0-rc1 | 11.2.4 |
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.2 |
8 more packages
github.com/mattermost/mattermost-server Go | From 11.3.0-rc1 | 11.3.2 |
github.com/mattermost/mattermost-server Go | From 11.4.0-rc1 | 11.4.1 |
github.com/mattermost/mattermost-server Go | From 11.4.0-rc1 | 11.4.1 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | 8.0.0-20260217110922-b7d4a1f1f59b |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-27656?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.12, 10.11.12+incompatible, 11.2.4+incompatible or 11.3.2+incompatible.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-27656 being exploited?
There is no known exploitation of CVE-2026-27656 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-fg35-5rf6-qg3g, GO-2026-5360.