CVE-2026-27659 CSRF vulnerability in UpdateAccessControlPolicyActiveStatus endpoint
Attackers can trick admins into modifying access control policy status via CSRF, requiring an upgrade to Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27659?
CVE-2026-27659 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 25 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to properly validate CSRF tokens in the /api/v4/access_control_policies/{policy_id}/activate endpoint, which allows an attacker to trick an admin into changing access control policy active status via a crafted request.. Mattermost Advisory ID: MMSA-2026-00578
Weakness: CWE-352
Which versions are affected by CVE-2026-27659?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0-rc1 | 10.11.11 |
github.com/mattermost/mattermost/server/v8 Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.2.0-rc1 | 11.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 11.3.0-rc1 | 11.3.2 |
github.com/mattermost/mattermost/server/v8 Go | From 11.3.0-rc1 | 11.3.2 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0-rc1 | 11.4.1 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0-rc1 | 11.4.1 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | 10.11.11 |
github.com/mattermost/mattermost/server/v8 Go | From 8.0.0-20260105080200-d27a2195068d | 10.11.11 |
github.com/mattermost/mattermost-server Go | From 10.11.0-rc1+incompatible | 10.11.11+incompatible, 11.2.3+incompatible, 11.3.2+incompatible, 11.4.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-27659?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 10.11.11, 11.2.3, 11.3.2 or 11.4.1.
Is CVE-2026-27659 being exploited?
There is no known exploitation of CVE-2026-27659 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-rmhw-c3xr-m3xx, GO-2026-5629.