# CVE-2026-27660: Gitea draft releases use insufficient permission checks

> Attackers can access draft release data and attachments without write permissions, exposing sensitive information in Gitea instances.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** GHSA-x92v-f5gc-r34v, GO-2026-6347, openSUSE-SU-2026:11846-1, openSUSE-SU-2026:12178-1

## What is CVE-2026-27660?

CVE-2026-27660 is a high-severity missing authorization vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gitea versions before 1.25.5 allow draft release data or attachments to be accessed without the required write permission.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-27660?

3 open source packages ship an affected version, including code.gitea.io/gitea.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `code.gitea.io/gitea` | Go | All versions | 1.25.5 |
| `forgejo` | openSUSE:Tumbleweed | All versions | 17.0.0-1.1 |
| `forgejo-longterm` | openSUSE:Tumbleweed | All versions | 15.0.8-1.1 |

## How do I fix CVE-2026-27660?

Upgrade code.gitea.io/gitea to 1.25.5 or later.

## Is CVE-2026-27660 being exploited?

There is no known exploitation of CVE-2026-27660 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27660 and fix it if it is affected.

What it is: CVE-2026-27660 is a high-severity missing authorization vulnerability in Gitea Open Source Git Server, published on 3 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27660 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5
- code.gitea.io/gitea (Go): affected all versions; fixed in 1.25.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27660/ (Markdown: https://insights.sbomify.com/CVE-2026-27660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27660
- OSV: https://osv.dev/vulnerability/CVE-2026-27660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27660/
Summaries are generated and may contain mistakes; the official description above is the record.
