# CVE-2026-27690: HTTP Request Smuggling in SAP Approuter

> An unauthenticated attacker can exploit HTTP request smuggling in SAP Approuter to expose user data and cause system unavailability.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-8m85-wqg7-c529

## What is CVE-2026-27690?

CVE-2026-27690 is a critical vulnerability in SAP_SE SAP Approuter, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Due to an HTTP Request Smuggling vulnerability in SAP Approuter, an unauthenticated attacker could send a specially crafted HTTP request that leads to request-response desynchronization. This could result in the exposure of user responses and cause the system to become unavailable. This leads to a high impact on confidentiality and availability.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-27690?

2 open source packages ship an affected version, including @sap/approuter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sap/approuter` | npm | All versions | 20.10.0 |
| `@sap/approuter` | npm | All versions | 20.10.0 |

Products: Sap Approuter.

## How do I fix CVE-2026-27690?

Upgrade @sap/approuter to 20.10.0 or later.

## Is CVE-2026-27690 being exploited?

There is no known exploitation of CVE-2026-27690 in the wild and no public exploit code.

## Other vulnerabilities in SAP_SE SAP Approuter

- [CVE-2026-44745](https://insights.sbomify.com/CVE-2026-44745/): Open Redirect vulnerability in SAP Approuter (high 8.1)
- [CVE-2026-58230](https://insights.sbomify.com/CVE-2026-58230/): Multiple vulnerabilities in SAP Business AI Platform (Approuter) (high 7.0)
- [CVE-2026-66760](https://insights.sbomify.com/CVE-2026-66760/): Multiple vulnerabilities in SAP Business AI Platform (Approuter) (medium 6.4)
- [CVE-2026-58237](https://insights.sbomify.com/CVE-2026-58237/): Multiple vulnerabilities in SAP Business AI Platform (Approuter) (medium 5.9)
- [CVE-2026-58238](https://insights.sbomify.com/CVE-2026-58238/): Multiple vulnerabilities in SAP Business AI Platform (Approuter) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27690 and fix it if it is affected.

What it is: CVE-2026-27690 is a critical vulnerability in SAP_SE SAP Approuter, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27690 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sap/approuter (npm): affected all versions; fixed in 20.10.0
- @sap/approuter (npm): affected all versions; fixed in 20.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27690/ (Markdown: https://insights.sbomify.com/CVE-2026-27690/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27690
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27690
- OSV: https://osv.dev/vulnerability/CVE-2026-27690

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27690/
Summaries are generated and may contain mistakes; the official description above is the record.
