{"answers":{"affected":"3 open source packages ship an affected version, including zae-limiter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27695 in the wild and no public exploit code.","fix":"Upgrade zae-limiter to 0.10.1 or later.","what":"CVE-2026-27695 is a medium-severity denial of service vulnerability in zeroae zae-limiter, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27695 and fix it if it is affected.\n\nWhat it is: CVE-2026-27695 is a medium-severity denial of service vulnerability in zeroae zae-limiter, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27695 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zae-limiter (PyPI): affected all versions; fixed in 0.10.1\n- zae-limiter (PyPI): affected all versions; fixed in 0.10.1\n- zae-limiter (PyPI): affected all versions; fixed in 0.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27695/ (Markdown: https://insights.sbomify.com/CVE-2026-27695/index.md)","id":"CVE-2026-27695","markdown":"https://insights.sbomify.com/CVE-2026-27695/index.md","name":"CVE-2026-27695","record":{"aliases":["GHSA-76rv-2r9v-c5m6","PYSEC-2026-3434"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python rate limiting library","requires_auth":"low_privilege","summary":"Attackers can cause denial of service for specific entities by exploiting DynamoDB partition throttling in the zae-limiter library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"zae-limiter","vendor":"zeroae"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"zae-limiter is a rate limiting library using the token bucket algorithm. Prior to version 0.10.1, all rate limit buckets for a single entity share the same DynamoDB partition key (`namespace/ENTITY#{id}`). A high-traffic entity can exceed DynamoDB's per-partition throughput limits (~1,000 WCU/sec), causing throttling that degrades service for that entity — and potentially co-located entities in the same partition. Version 0.10.1 fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"zae-limiter: DynamoDB hot partition throttling enables per-entity Denial of Service","id":"CVE-2026-27695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs","id":"CVE-2026-27696"},"packages":[{"ecosystem":"PyPI","fixed":["0.10.1"],"introduced":["0"],"last_affected":[],"package":"zae-limiter","purl":null,"source":"GHSA-76rv-2r9v-c5m6"},{"ecosystem":"PyPI","fixed":["0.10.1"],"introduced":["0"],"last_affected":[],"package":"zae-limiter","purl":"pkg:pypi/zae-limiter","source":"GHSA-76rv-2r9v-c5m6"},{"ecosystem":"PyPI","fixed":["0.10.1"],"introduced":["0"],"last_affected":[],"package":"zae-limiter","purl":"pkg:pypi/zae-limiter","source":"PYSEC-2026-3434"}],"prev":{"headline":"traccar allows stored HTML injection in notification emails","id":"CVE-2026-27694"},"products":["zae-limiter"],"published":"2026-02-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["zeroae"]},"summary":"Attackers can cause denial of service for specific entities by exploiting DynamoDB partition throttling in the zae-limiter library.","url":"https://insights.sbomify.com/CVE-2026-27695/"}