# CVE-2026-27695: zae-limiter: DynamoDB hot partition throttling enables per-entity Denial of Service

> Attackers can cause denial of service for specific entities by exploiting DynamoDB partition throttling in the zae-limiter library.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-76rv-2r9v-c5m6, PYSEC-2026-3434

## What is CVE-2026-27695?

CVE-2026-27695 is a medium-severity denial of service vulnerability in zeroae zae-limiter, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

zae-limiter is a rate limiting library using the token bucket algorithm. Prior to version 0.10.1, all rate limit buckets for a single entity share the same DynamoDB partition key (`namespace/ENTITY#{id}`). A high-traffic entity can exceed DynamoDB's per-partition throughput limits (~1,000 WCU/sec), causing throttling that degrades service for that entity — and potentially co-located entities in the same partition. Version 0.10.1 fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-27695?

3 open source packages ship an affected version, including zae-limiter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zae-limiter` | PyPI | All versions | 0.10.1 |
| `zae-limiter` | PyPI | All versions | 0.10.1 |
| `zae-limiter` | PyPI | All versions | 0.10.1 |

Products: Zeroae Zae-Limiter.

## How do I fix CVE-2026-27695?

Upgrade zae-limiter to 0.10.1 or later.

## Is CVE-2026-27695 being exploited?

There is no known exploitation of CVE-2026-27695 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27695 and fix it if it is affected.

What it is: CVE-2026-27695 is a medium-severity denial of service vulnerability in zeroae zae-limiter, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27695 in the wild and no public exploit code.

Affected packages and fixed versions:
- zae-limiter (PyPI): affected all versions; fixed in 0.10.1
- zae-limiter (PyPI): affected all versions; fixed in 0.10.1
- zae-limiter (PyPI): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27695/ (Markdown: https://insights.sbomify.com/CVE-2026-27695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27695
- OSV: https://osv.dev/vulnerability/CVE-2026-27695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27695/
Summaries are generated and may contain mistakes; the official description above is the record.
