# CVE-2026-27696: changedetection.io Vulnerable to Server-Side Request Forgery (SSRF) via Watch URLs

> An attacker can exploit SSRF in changedetection.io to access internal network resources and exfiltrate sensitive data via watch URLs.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-3c45-4pj5-ch7m, PYSEC-2026-2126

## What is CVE-2026-27696?

CVE-2026-27696 is a high-severity server-side request forgery vulnerability in dgtlmoon changedetection.io, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

changedetection.io is a free open source web page change detection tool. In versions prior to 0.54.1, changedetection.io is vulnerable to Server-Side Request Forgery (SSRF) because the URL validation function `is_safe_valid_url()` does not validate the resolved IP address of watch URLs against private, loopback, or link-local address ranges. An authenticated user (or any user when no password is configured, which is the default) can add a watch for internal network URLs. The application fetches these URLs server-side, stores the response content, and makes it viewable through the web UI — enabling full data exfiltration from internal services. Version 0.54.1 contains a fix for the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-27696?

3 open source packages ship an affected version, including changedetection.io and changedetection-io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `changedetection.io` | PyPI | All versions | 0.54.1 |
| `changedetection-io` | PyPI | All versions | 0.54.1 |
| `changedetection-io` | PyPI | All versions | 0.54.1 |

Products: Webtechnologies Changedetection.

## How do I fix CVE-2026-27696?

Upgrade changedetection.io to 0.54.1 or later.

## Is CVE-2026-27696 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27696 exists.

## Other vulnerabilities in dgtlmoon changedetection.io

- [CVE-2026-35490](https://insights.sbomify.com/CVE-2026-35490/): changedetection.io has an Authentication Bypass via Decorator Ordering (critical 9.8)
- [CVE-2026-29039](https://insights.sbomify.com/CVE-2026-29039/): changedetection.io: XPath - Arbitrary File Read via unparsed-text() (high 8.8)
- [CVE-2026-29065](https://insights.sbomify.com/CVE-2026-29065/): changedetection.io: Zip Slip vulnerability in the backup restore functionality (high 8.8)
- [CVE-2026-33981](https://insights.sbomify.com/CVE-2026-33981/): Changedetection.io Discloses Environment Variables via jq env Builtin in Include Filters (high 8.3)
- [CVE-2026-41895](https://insights.sbomify.com/CVE-2026-41895/): changedetection.io: XXE vulnerability in the changedetection.io project (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27696 and fix it if it is affected.

What it is: CVE-2026-27696 is a high-severity server-side request forgery vulnerability in dgtlmoon changedetection.io, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27696 exists.

Affected packages and fixed versions:
- changedetection.io (PyPI): affected all versions; fixed in 0.54.1
- changedetection-io (PyPI): affected all versions; fixed in 0.54.1
- changedetection-io (PyPI): affected all versions; fixed in 0.54.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27696/ (Markdown: https://insights.sbomify.com/CVE-2026-27696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27696
- OSV: https://osv.dev/vulnerability/CVE-2026-27696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27696/
Summaries are generated and may contain mistakes; the official description above is the record.
