# CVE-2026-27702: Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud)

> Authenticated users can execute arbitrary JavaScript on Budibase Cloud servers via unsafe eval, leading to code execution and data theft.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-rvhr-26g4-p2r8

## What is CVE-2026-27702?

CVE-2026-27702 is a critical code injection vulnerability in budibase, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Budibase is a low code platform for creating internal tools, workflows, and admin panels. Prior to version 3.30.4, an unsafe `eval()` vulnerability in Budibase's view filtering implementation allows any authenticated user (including free tier accounts) to execute arbitrary JavaScript code on the server. This vulnerability ONLY affects Budibase Cloud (SaaS) - self-hosted deployments use native CouchDB views and are not vulnerable. The vulnerability exists in `packages/server/src/db/inMemoryView.ts` where user-controlled view map functions are directly evaluated without sanitization. The primary impact comes from what lives inside the pod's environment: the `app-service` pod runs with secrets baked into its environment variables, including `INTERNAL_API_KEY`, `JWT_SECRET`, CouchDB admin credentials, AWS keys, and more. Using the extracted CouchDB credentials, we verified direct database access, enumerated all tenant databases, and confirmed that user records (email addresses) are readable. Version 3.30.4 contains a patch.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code), CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-27702?

2 open source packages ship an affected version, including budibase. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `budibase` | npm | All versions | 3.30.4 |
| `budibase` | npm | All versions | 3.30.4 |

Products: Budibase Budibase.

## How do I fix CVE-2026-27702?

Upgrade budibase to 3.30.4 or later.

## Is CVE-2026-27702 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27702 exists.

## Other vulnerabilities in budibase

- [CVE-2026-54350](https://insights.sbomify.com/CVE-2026-54350/): Budibase: Anonymous NoSQL operator injection via published-app query templates (critical 10.0)
- [CVE-2026-54352](https://insights.sbomify.com/CVE-2026-54352/): Budibase: Arbitrary file read by workspace-builder via PWA-zip symlink upload (critical 9.6)
- [CVE-2026-31818](https://insights.sbomify.com/CVE-2026-31818/): Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist (critical 9.6)
- [CVE-2026-30240](https://insights.sbomify.com/CVE-2026-30240/): Budibase PWA ZIP Upload Path Traversal Allows Reading Arbitrary Server Files Including All Environment Secrets (critical 9.6)
- [CVE-2026-41428](https://insights.sbomify.com/CVE-2026-41428/): Budibase: Authentication Bypass via Unanchored Regex in Public Endpoint Matcher — Unauthenticated Access to Protected Endpoints (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27702 and fix it if it is affected.

What it is: CVE-2026-27702 is a critical code injection vulnerability in budibase, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27702 exists.

Affected packages and fixed versions:
- budibase (npm): affected all versions; fixed in 3.30.4
- budibase (npm): affected all versions; fixed in 3.30.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27702/ (Markdown: https://insights.sbomify.com/CVE-2026-27702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27702
- OSV: https://osv.dev/vulnerability/CVE-2026-27702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27702/
Summaries are generated and may contain mistakes; the official description above is the record.
