CVE-2026-27727 mchange-commons-java: Remote Code Execution via JNDI Reference Resolution
Attackers can achieve remote code execution by triggering JNDI reference resolution in mchange-commons-java, bypassing JDK security hardening.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27727?
CVE-2026-27727 is a high-severity unsafe deserialization vulnerability in swaldman mchange-commons-java, published on 25 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
mchange-commons-java, a library that provides Java utilities, includes code that mirrors early implementations of JNDI functionality, including support for remote `factoryClassLocation` values, by which code can be downloaded and invoked within a running application. If an attacker can provoke an application to read a maliciously crafted `jaxax.naming.Reference` or serialized object, they can provoke the download and execution of malicious code. Implementations of this functionality within the JDK were disabled by default behind a System property that defaults to `false`, `com.sun.jndi.ldap.object.trustURLCodebase`. However, since mchange-commons-java includes an independent implementation of JNDI derefencing, libraries (such as c3p0) that resolve references via that implementation could be provoked to download and execute malicious code even after the JDK was hardened. Mirroring the JDK patch, mchange-commons-java's JNDI functionality is gated by configuration parameters that default to restrictive values starting in version 0.4.0. No known workarounds are available. Versions prior to 0.4.0 should be avoided on application CLASSPATHs.
Which versions are affected by CVE-2026-27727?
2 open source packages ship an affected version, including com.mchange:mchange-commons-java. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.mchange:mchange-commons-java Maven | All versions | 0.4.0 |
com.mchange:mchange-commons-java Maven | All versions | 0.4.0 |
Linux distribution packages (2)
c3p0 openSUSE:Tumbleweed | All versions | 0.12.0-1.1 |
mchange-commons openSUSE:Tumbleweed | All versions | 0.4.0-1.1 |
Products include Mchange Mchange Commons Java.
How do I fix CVE-2026-27727?
Upgrade com.mchange:mchange-commons-java to 0.4.0 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-27727 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27727 exists.
Sources
Also known as CLSA-2026-1783991044, CLSA-2026-1784077469, CLSA-2026-1784077513, ECHO-9e62-e526-bbc8, GHSA-m2cm-222f-qw44, MINI-7mhp-98p7-445x and 4 more.