# CVE-2026-27727: mchange-commons-java: Remote Code Execution via JNDI Reference Resolution

> Attackers can achieve remote code execution by triggering JNDI reference resolution in mchange-commons-java, bypassing JDK security hardening.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 15 Sep 2026
- **Also known as:** CLSA-2026-1783991044, CLSA-2026-1784077469, CLSA-2026-1784077513, ECHO-9e62-e526-bbc8, GHSA-m2cm-222f-qw44, MINI-7mhp-98p7-445x, OESA-2026-1690, UBUNTU-CVE-2026-27727, openSUSE-SU-2026:10279-1, openSUSE-SU-2026:10281-1

## What is CVE-2026-27727?

CVE-2026-27727 is a high-severity unsafe deserialization vulnerability in swaldman mchange-commons-java, published on 25 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

mchange-commons-java, a library that provides Java utilities, includes code that mirrors early implementations of JNDI functionality, including support for remote `factoryClassLocation` values, by which code can be downloaded and invoked within a running application. If an attacker can provoke an application to read a maliciously crafted `jaxax.naming.Reference` or serialized object, they can provoke the download and execution of malicious code. Implementations of this functionality within the JDK were disabled by default behind a System property that defaults to `false`, `com.sun.jndi.ldap.object.trustURLCodebase`. However, since mchange-commons-java includes an independent implementation of JNDI derefencing, libraries (such as c3p0) that resolve references via that implementation could be provoked to download and execute malicious code even after the JDK was hardened. Mirroring the JDK patch, mchange-commons-java's JNDI functionality is gated by configuration parameters that default to restrictive values starting in version 0.4.0. No known workarounds are available. Versions prior to 0.4.0 should be avoided on application CLASSPATHs.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-27727?

2 open source packages ship an affected version, including com.mchange:mchange-commons-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.mchange:mchange-commons-java` | Maven | All versions | 0.4.0 |
| `com.mchange:mchange-commons-java` | Maven | All versions | 0.4.0 |
| `c3p0` | openSUSE:Tumbleweed | All versions | 0.12.0-1.1 |
| `mchange-commons` | openSUSE:Tumbleweed | All versions | 0.4.0-1.1 |

Products: Mchange Mchange Commons Java.

## How do I fix CVE-2026-27727?

Upgrade com.mchange:mchange-commons-java to 0.4.0 or later.

## Is CVE-2026-27727 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27727 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27727 and fix it if it is affected.

What it is: CVE-2026-27727 is a high-severity unsafe deserialization vulnerability in swaldman mchange-commons-java, published on 25 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27727 exists.

Affected packages and fixed versions:
- com.mchange:mchange-commons-java (Maven): affected all versions; fixed in 0.4.0
- com.mchange:mchange-commons-java (Maven): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27727/ (Markdown: https://insights.sbomify.com/CVE-2026-27727/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27727
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27727
- OSV: https://osv.dev/vulnerability/CVE-2026-27727

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27727/
Summaries are generated and may contain mistakes; the official description above is the record.
