CVE-2026-27738 Angular SSR has an Open Redirect via X-Forwarded-Prefix
Attackers can exploit improper URL normalization in Angular SSR to perform open redirects, enabling phishing and SEO hijacking when specific proxy headers are used.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27738?
CVE-2026-27738 is a medium-severity vulnerability in angular-cli, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Angular SSR is a server-rise rendering tool for Angular applications. An Open Redirect vulnerability exists in the internal URL processing logic in versions on the 19.x branch prior to 19.2.21, the 20.x branch prior to 20.3.17, and the 21.x branch prior to 21.1.5 and 21.2.0-rc.1. The logic normalizes URL segments by stripping leading slashes; however, it only removes a single leading slash. When an Angular SSR application is deployed behind a proxy that passes the `X-Forwarded-Prefix` header, an attacker can provide a value starting with three slashes. This vulnerability allows attackers to conduct large-scale phishing and SEO hijacking. In order to be vulnerable, the application must use Angular SSR, the application must have routes that perform internal redirects, the infrastructure (Reverse Proxy/CDN) must pass the `X-Forwarded-Prefix` header to the SSR process without sanitization, and the cache must not vary on the `X-Forwarded-Prefix` header. Versions 21.2.0-rc.1, 21.1.5, 20.3.17, and 19.2.21 contain a patch. Until the patch is applied, developers should sanitize the `X-Forwarded-Prefix` header in their`server.ts` before the Angular engine processes the request.
Weakness: CWE-601
Which versions are affected by CVE-2026-27738?
8 open source packages ship an affected version, including @angular/ssr.
| Package | Affected | Fixed in |
|---|---|---|
@angular/ssr npm | From 19.0.0-next.0 | 19.2.21 |
@angular/ssr npm | From 19.0.0-next.0 | 19.2.21 |
@angular/ssr npm | From 20.0.0-next.0 | 20.3.17 |
@angular/ssr npm | From 20.0.0-next.0 | 20.3.17 |
@angular/ssr npm | From 21.0.0-next.0 | 21.1.5 |
@angular/ssr npm | From 21.0.0-next.0 | 21.1.5 |
2 more packages
@angular/ssr npm | From 21.2.0-next.0 | 21.2.0-rc.1 |
@angular/ssr npm | From 21.2.0-next.0 | 21.2.0-rc.1 |
How do I fix CVE-2026-27738?
Upgrade @angular/ssr to a fixed version for your release line: 19.2.21, 20.3.17, 21.1.5 or 21.2.0-rc.1.
Is CVE-2026-27738 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27738 exists.
Sources
Also known as GHSA-xh43-g2fq-wjrj.