# CVE-2026-27739: Angular SSR is vulnerable to SSRF and Header Injection via request handling pipeline

> Attackers can exploit unvalidated headers in Angular SSR to perform Server-Side Request Forgery, enabling internal network probing and credential exfiltration.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 27 Feb 2026
- **Also known as:** CLSA-2026-1776645366, CLSA-2026-1776645367, CLSA-2026-1778460307, CLSA-2026-1792163460, CLSA-2026-1792163461, CLSA-2026-1792202606, CLSA-2026-1792248406, CLSA-2026-1792248407, CLSA-2026-1792279521, CLSA-2026-1792279522, CLSA-2026-1792327352, CLSA-2026-1792327353, CLSA-2026-1792339029, CLSA-2026-1792339030, CLSA-2026-1792348145, CLSA-2026-1792348147, CLSA-2026-1792358881, CLSA-2026-1792358883, CLSA-2026-1792364739, CLSA-2026-1792364740, CLSA-2026-1792865280, GHSA-x288-3778-4hhx

## What is CVE-2026-27739?

CVE-2026-27739 is a critical server-side request forgery vulnerability in angular @nguniversal/common, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Angular SSR is a server-rise rendering tool for Angular applications. Versions prior to 21.2.0-rc.1, 21.1.5, 20.3.17, and 19.2.21 have a Server-Side Request Forgery (SSRF) vulnerability in the Angular SSR request handling pipeline. The vulnerability exists because Angular’s internal URL reconstruction logic directly trusts and consumes user-controlled HTTP headers specifically the Host and `X-Forwarded-*` family to determine the application's base origin without any validation of the destination domain. Specifically, the framework didn't have checks for the host domain, path and character sanitization, and port validation. This vulnerability manifests in two primary ways: implicit relative URL resolution and explicit manual construction. When successfully exploited, this vulnerability allows for arbitrary internal request steering. This can lead to credential exfiltration, internal network probing, and a confidentiality breach. In order to be vulnerable, the victim application must use Angular SSR (Server-Side Rendering), the application must perform `HttpClient` requests using relative URLs OR manually construct URLs using the unvalidated `Host` / `X-Forwarded-*` headers using the `REQUEST` object, the application server must be reachable by an attacker who can influence these headers without strict validation from a front-facing proxy, and the infrastructure (Cloud, CDN, or Load Balancer) must not sanitize or validate incoming headers. Versions 21.2.0-rc.1, 21.1.5, 20.3.17, and 19.2.21 contain a patch. Some workarounds are available. Avoid using `req.headers` for URL construction. Instead, use trusted variables for base API paths. Those who cannot upgrade immediately should implement a middleware in their `server.ts` to enforce numeric ports and validated hostnames.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-27739?

12 open source packages ship an affected version, including @angular/ssr, @nguniversal/common and @nguniversal/express-engine.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/ssr` | npm | All versions | 19.2.21 |
| `@angular/ssr` | npm | All versions | 19.2.21 |
| `@angular/ssr` | npm | From 20.0.0-next.0 | 20.3.17 |
| `@angular/ssr` | npm | From 20.0.0-next.0 | 20.3.17 |
| `@angular/ssr` | npm | From 21.0.0-next.0 | 21.1.5 |
| `@angular/ssr` | npm | From 21.0.0-next.0 | 21.1.5 |
| `@angular/ssr` | npm | From 21.2.0-next.0 | 21.2.0-rc.1 |
| `@angular/ssr` | npm | From 21.2.0-next.0 | 21.2.0-rc.1 |
| `@nguniversal/common` | npm | All versions to 16.2.0 | None |
| `@nguniversal/common` | npm | All versions to 16.2.0 | None |
| `@nguniversal/express-engine` | npm | All versions to 16.2.0 | None |
| `@nguniversal/express-engine` | npm | All versions to 16.2.0 | None |

## How do I fix CVE-2026-27739?

Upgrade @angular/ssr to a fixed version for your release line: 19.2.21, 20.3.17, 21.1.5 or 21.2.0-rc.1.

## Is CVE-2026-27739 being exploited?

There is no known exploitation of CVE-2026-27739 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mr-redoo7/CVE-2026-27739-POC (github_poc): https://github.com/mr-redoo7/CVE-2026-27739-POC
- Proof-of-concept scanner for SSRF and header injection in Angular Universal SSR apps. For authorized security testing only (github_poc): https://github.com/Mr-Red-007/CVE-2026-27739-POC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27739 and fix it if it is affected.

What it is: CVE-2026-27739 is a critical server-side request forgery vulnerability in angular @nguniversal/common, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27739 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/ssr (npm): affected all versions; fixed in 19.2.21
- @angular/ssr (npm): affected all versions; fixed in 19.2.21
- @angular/ssr (npm): affected from 20.0.0-next.0; fixed in 20.3.17
- @angular/ssr (npm): affected from 20.0.0-next.0; fixed in 20.3.17
- @angular/ssr (npm): affected from 21.0.0-next.0; fixed in 21.1.5
- @angular/ssr (npm): affected from 21.0.0-next.0; fixed in 21.1.5
- @angular/ssr (npm): affected from 21.2.0-next.0; fixed in 21.2.0-rc.1
- @angular/ssr (npm): affected from 21.2.0-next.0; fixed in 21.2.0-rc.1
- @nguniversal/common (npm): affected all versions up to 16.2.0; no fix listed
- @nguniversal/common (npm): affected all versions up to 16.2.0; no fix listed
- @nguniversal/express-engine (npm): affected all versions up to 16.2.0; no fix listed
- @nguniversal/express-engine (npm): affected all versions up to 16.2.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27739/ (Markdown: https://insights.sbomify.com/CVE-2026-27739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27739
- OSV: https://osv.dev/vulnerability/CVE-2026-27739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27739/
Summaries are generated and may contain mistakes; the official description above is the record.
