# CVE-2026-27769: Connected Workspaces: Malicious remote server can manipulate arbitrary user's status

> A malicious remote server can manipulate the displayed status of arbitrary local users in Mattermost when the Connected Workspaces feature is enabled.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-mxxh-fmjq-j6x4, GO-2026-5522

## What is CVE-2026-27769?

CVE-2026-27769 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 15 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.12 fail to validate whether users were correctly owned by the correct Connected Workspace which allows a malicious remote server connected using the Conntexted Workspaces feature to change the displayed status of local users via the Connected Workspaces API.. Mattermost Advisory ID: MMSA-2026-00603

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-27769?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20260316060126-bc1a2b34b1f9 |
| `github.com/mattermost/mattermost-server` | Go | From 8.0.0-20250721062209-4952acea88ce | 8.0.0-20260316060126-bc1a2b34b1f9 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2026-27769?

Upgrade github.com/mattermost/mattermost-server to 8.0.0-20260316060126-bc1a2b34b1f9 or later.

## Is CVE-2026-27769 being exploited?

There is no known exploitation of CVE-2026-27769 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27769 and fix it if it is affected.

What it is: CVE-2026-27769 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 15 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27769 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 8.0.0-20250721062209-4952acea88ce; fixed in 8.0.0-20260316060126-bc1a2b34b1f9
- github.com/mattermost/mattermost-server (Go): affected from 8.0.0-20250721062209-4952acea88ce; fixed in 8.0.0-20260316060126-bc1a2b34b1f9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27769/ (Markdown: https://insights.sbomify.com/CVE-2026-27769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27769
- OSV: https://osv.dev/vulnerability/CVE-2026-27769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27769/
Summaries are generated and may contain mistakes; the official description above is the record.
