# CVE-2026-27794: LangGraph: BaseCache Deserialization of Untrusted Data may lead to Remote Code Execution

> Attackers with write access to the cache backend can achieve remote code execution via unsafe pickle deserialization in LangGraph's caching layer.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** CLSA-2026-1780966309, ECHO-1e62-5969-14f5, GHSA-mhr3-j7m5-c7c9, PYSEC-2026-2574

## What is CVE-2026-27794?

CVE-2026-27794 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph-checkpoint, published on 25 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LangGraph Checkpoint defines the base interface for LangGraph checkpointers. Prior to version 4.0.0, a Remote Code Execution vulnerability exists in LangGraph's caching layer when applications enable cache backends that inherit from `BaseCache` and opt nodes into caching via `CachePolicy`. Prior to `langgraph-checkpoint` 4.0.0, `BaseCache` defaults to `JsonPlusSerializer(pickle_fallback=True)`. When msgpack serialization fails, cached values can be deserialized via `pickle.loads(...)`. Caching is not enabled by default. Applications are affected only when the application explicitly enables a cache backend (for example by passing `cache=...` to `StateGraph.compile(...)` or otherwise configuring a `BaseCache` implementation), one or more nodes opt into caching via `CachePolicy`, and the attacker can write to the cache backend (for example a network-accessible Redis instance with weak/no auth, shared cache infrastructure reachable by other tenants/services, or a writable SQLite cache file). An attacker must be able to write attacker-controlled bytes into the cache backend such that the LangGraph process later reads and deserializes them. This typically requires write access to a networked cache (for example a network-accessible Redis instance with weak/no auth or shared cache infrastructure reachable by other tenants/services) or write access to local cache storage (for example a writable SQLite cache file via permissive file permissions or a shared writable volume). Because exploitation requires write access to the cache storage layer, this is a post-compromise / post-access escalation vector. LangGraph Checkpoint 4.0.0 patches the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-27794?

3 open source packages ship an affected version, including langgraph-checkpoint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-checkpoint` | PyPI | All versions | 4.0.0 |
| `langgraph-checkpoint` | PyPI | All versions | 4.0.0 |
| `langgraph-checkpoint` | PyPI | All versions | 4.0.0 |

## How do I fix CVE-2026-27794?

Upgrade langgraph-checkpoint to 4.0.0 or later.

## Is CVE-2026-27794 being exploited?

There is no known exploitation of CVE-2026-27794 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27794 and fix it if it is affected.

What it is: CVE-2026-27794 is a medium-severity unsafe deserialization vulnerability in langchain-ai langgraph-checkpoint, published on 25 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27794 in the wild and no public exploit code.

Affected packages and fixed versions:
- langgraph-checkpoint (PyPI): affected all versions; fixed in 4.0.0
- langgraph-checkpoint (PyPI): affected all versions; fixed in 4.0.0
- langgraph-checkpoint (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27794/ (Markdown: https://insights.sbomify.com/CVE-2026-27794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27794
- OSV: https://osv.dev/vulnerability/CVE-2026-27794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27794/
Summaries are generated and may contain mistakes; the official description above is the record.
