{"answers":{"affected":"2 open source packages ship an affected version, including @langchain/community. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27795 in the wild and no public exploit code.","fix":"Upgrade @langchain/community to 1.1.18 or later.","what":"CVE-2026-27795 is a medium-severity server-side request forgery vulnerability in langchain-ai langchainjs, published on 25 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-27795 and fix it if it is affected.\n\nWhat it is: CVE-2026-27795 is a medium-severity server-side request forgery vulnerability in langchain-ai langchainjs, published on 25 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-27795 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @langchain/community (npm): affected all versions; fixed in 1.1.18\n- @langchain/community (npm): affected all versions; fixed in 1.1.18\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27795/ (Markdown: https://insights.sbomify.com/CVE-2026-27795/index.md)","id":"CVE-2026-27795","markdown":"https://insights.sbomify.com/CVE-2026-27795/index.md","name":"CVE-2026-27795","record":{"aliases":["CLEANSTART-2026-UF69839","ECHO-70ce-6dbc-a4c4","GHSA-mphv-75cg-56wg","MINI-4g97-4rc3-7rr2","MINI-692w-68m4-hx6w","MINI-846h-gh66-c7v5","MINI-859g-rxw3-vq8p","MINI-gjfc-f949-gjq2","MINI-jmf2-6fqp-8r26","MINI-m2fq-6jw8-2hv9","MINI-q6j2-pcqq-q9cx","ROOT-APP-NPM-CVE-2026-27795"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LangChain JS library","requires_auth":"low_privilege","summary":"Attackers can bypass SSRF protections in RecursiveUrlLoader by chaining redirects to access internal endpoints, requiring an upgrade to the LangChain community package.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"langchain_community","vendor":"langchain"}],"cvss":{"score":4.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"LangChain is a framework for building LLM-powered applications. Prior to version 1.1.8, a redirect-based Server-Side Request Forgery (SSRF) bypass exists in `RecursiveUrlLoader` in `@langchain/community`. The loader validates the initial URL but allows the underlying fetch to follow redirects automatically, which permits a transition from a safe public URL to an internal or metadata endpoint without revalidation. This is a bypass of the SSRF protections introduced in 1.1.14 (CVE-2026-26019). Users should upgrade to `@langchain/community` 1.1.18, which validates every redirect hop by disabling automatic redirects and re-validating `Location` targets before following them. In this version, automatic redirects are disabled (`redirect: \"manual\"`), each 3xx `Location` is resolved and validated with `validateSafeUrl()` before the next request, and a maximum redirect limit prevents infinite loops.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LangChain Community: redirect chaining can lead to SSRF bypass via RecursiveUrlLoader","id":"CVE-2026-27795","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":7,"next":{"headline":"Homarr: Unauthenticated Information Disclosure (Integration Metadata Leak)","id":"CVE-2026-27796"},"packages":[{"ecosystem":"npm","fixed":["1.1.18"],"introduced":["0"],"last_affected":[],"package":"@langchain/community","purl":null,"source":"GHSA-mphv-75cg-56wg"},{"ecosystem":"npm","fixed":["1.1.18"],"introduced":["0"],"last_affected":[],"package":"@langchain/community","purl":"pkg:npm/%40langchain/community","source":"GHSA-mphv-75cg-56wg"}],"prev":{"headline":"LangGraph: BaseCache Deserialization of Untrusted Data may lead to Remote Code Execution","id":"CVE-2026-27794"},"products":["langchainjs"],"published":"2026-02-25","related":[{"cvss_score":4.1,"headline":"@langchain/community affected by SSRF Bypass in RecursiveUrlLoader via insufficient URL origin validation","id":"CVE-2026-26019","kev_date_added":null,"published":"2026-02-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-25","vendors":["langchain-ai"]},"summary":"Attackers can bypass SSRF protections in RecursiveUrlLoader by chaining redirects to access internal endpoints, requiring an upgrade to the LangChain community package.","url":"https://insights.sbomify.com/CVE-2026-27795/"}