CVE-2026-27801 Vaultwarden: 2FA Bypass on Protected Actions due to Faulty Rate Limit Enforcement

Medium 6.0 Published Updated

Authenticated attackers can bypass 2FA to perform protected actions like deleting vaults or accessing API keys in Vaultwarden.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27801?

CVE-2026-27801 is a medium-severity vulnerability in dani-garcia vaultwarden, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.

Weakness: CWE-307

Which versions are affected by CVE-2026-27801?

2 open source packages ship an affected version, including vaultwarden. It affects 1 product.

PackageAffectedFixed in
vaultwarden crates.ioAll versions1.35.0
vaultwarden crates.ioAll versions1.35.0

Products include Dani-Garcia Vaultwarden.

How do I fix CVE-2026-27801?

Upgrade vaultwarden to 1.35.0 or later.

Is CVE-2026-27801 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27801 exists.

Sources

Also known as GHSA-v6pg-v89r-w8wr.

Is CVE-2026-27801 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free