# CVE-2026-27801: Vaultwarden: 2FA Bypass on Protected Actions due to Faulty Rate Limit Enforcement

> Authenticated attackers can bypass 2FA to perform protected actions like deleting vaults or accessing API keys in Vaultwarden.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 5 Mar 2026
- **Also known as:** GHSA-v6pg-v89r-w8wr

## What is CVE-2026-27801?

CVE-2026-27801 is a medium-severity vulnerability in dani-garcia vaultwarden, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-27801?

2 open source packages ship an affected version, including vaultwarden. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vaultwarden` | crates.io | All versions | 1.35.0 |
| `vaultwarden` | crates.io | All versions | 1.35.0 |

Products: Dani-Garcia Vaultwarden.

## How do I fix CVE-2026-27801?

Upgrade vaultwarden to 1.35.0 or later.

## Is CVE-2026-27801 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27801 exists.

## Other vulnerabilities in dani-garcia vaultwarden

- [CVE-2024-55225](https://insights.sbomify.com/CVE-2024-55225/): Vaultwarden vulnerable to user impersonation (critical 9.8)
- [CVE-2024-55224](https://insights.sbomify.com/CVE-2024-55224/): Vaultwarden HTML injection vulnerability (critical 9.6)
- [CVE-2024-39924](https://insights.sbomify.com/CVE-2024-39924/): Privilege escalation in n/a (high 8.8)
- [CVE-2026-43912](https://insights.sbomify.com/CVE-2026-43912/): Vaultwarden: Cross-Org Group Binding Enables Unauthorized Read And Write Access Into Another Organization (high 8.7)
- [CVE-2026-27802](https://insights.sbomify.com/CVE-2026-27802/): Vaultwarden: Privilege Escalation via Bulk Permission Update to Unauthorized Collections by Manager (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27801 and fix it if it is affected.

What it is: CVE-2026-27801 is a medium-severity vulnerability in dani-garcia vaultwarden, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27801 exists.

Affected packages and fixed versions:
- vaultwarden (crates.io): affected all versions; fixed in 1.35.0
- vaultwarden (crates.io): affected all versions; fixed in 1.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27801/ (Markdown: https://insights.sbomify.com/CVE-2026-27801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27801
- OSV: https://osv.dev/vulnerability/CVE-2026-27801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27801/
Summaries are generated and may contain mistakes; the official description above is the record.
