# CVE-2026-27802: Vaultwarden: Privilege Escalation via Bulk Permission Update to Unauthorized Collections by Manager

> A Manager user can escalate privileges by bulk updating permissions to access unauthorized collections in Vaultwarden.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 5 Mar 2026
- **Also known as:** GHSA-r32r-j5jq-3w4m

## What is CVE-2026-27802?

CVE-2026-27802 is a high-severity vulnerability in dani-garcia vaultwarden, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Prior to version 1.35.4, there is a privilege escalation vulnerability via bulk permission update to unauthorized collections by Manager. This issue has been patched in version 1.35.4.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-27802?

2 open source packages ship an affected version, including vaultwarden. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vaultwarden` | crates.io | All versions | 1.35.4 |
| `vaultwarden` | crates.io | All versions | 1.35.4 |

Products: Dani-Garcia Vaultwarden.

## How do I fix CVE-2026-27802?

Upgrade vaultwarden to 1.35.4 or later.

## Is CVE-2026-27802 being exploited?

There is no known exploitation of CVE-2026-27802 in the wild and no public exploit code.

## Other vulnerabilities in dani-garcia vaultwarden

- [CVE-2024-55225](https://insights.sbomify.com/CVE-2024-55225/): Vaultwarden vulnerable to user impersonation (critical 9.8)
- [CVE-2024-55224](https://insights.sbomify.com/CVE-2024-55224/): Vaultwarden HTML injection vulnerability (critical 9.6)
- [CVE-2024-39924](https://insights.sbomify.com/CVE-2024-39924/): Privilege escalation in n/a (high 8.8)
- [CVE-2026-43912](https://insights.sbomify.com/CVE-2026-43912/): Vaultwarden: Cross-Org Group Binding Enables Unauthorized Read And Write Access Into Another Organization (high 8.7)
- [CVE-2026-27803](https://insights.sbomify.com/CVE-2026-27803/): Vaultwarden: Collection Management Operations Allowed Without `manage` Verification for Manager Role (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27802 and fix it if it is affected.

What it is: CVE-2026-27802 is a high-severity vulnerability in dani-garcia vaultwarden, published on 4 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27802 in the wild and no public exploit code.

Affected packages and fixed versions:
- vaultwarden (crates.io): affected all versions; fixed in 1.35.4
- vaultwarden (crates.io): affected all versions; fixed in 1.35.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27802/ (Markdown: https://insights.sbomify.com/CVE-2026-27802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27802
- OSV: https://osv.dev/vulnerability/CVE-2026-27802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27802/
Summaries are generated and may contain mistakes; the official description above is the record.
