CVE-2026-27804 Parse Server: Account takeover via JWT algorithm confusion in Google auth adapter

Critical 9.3 Published Updated

Unauthenticated attackers can forge Google JWTs to take over accounts in Parse Server deployments with Google auth enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27804?

CVE-2026-27804 is a critical authentication bypass vulnerability in Parseplatform Parse-Server, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.3 and 9.1.1-alpha.4, an unauthenticated attacker can forge a Google authentication token with `alg: "none"` to log in as any user linked to a Google account, without knowing their credentials. All deployments with Google authentication enabled are affected. The fix in versions 8.6.3 and 9.1.1-alpha.4 hardcodes the expected `RS256` algorithm instead of trusting the JWT header, and replaces the Google adapter's custom key fetcher with `jwks-rsa` which rejects unknown key IDs. As a workaround, dsable Google authentication until upgrading is possible.

Weakness: CWE-345, CWE-327

Which versions are affected by CVE-2026-27804?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions8.6.3
parse-server npmAll versions8.6.3
parse-server npmFrom 9.0.09.3.1-alpha.4
parse-server npmFrom 9.0.09.3.1-alpha.4
parse BitnamiAll versions8.6.3, 9.3.1

Products include Parseplatform Parse-Server.

How do I fix CVE-2026-27804?

Upgrade parse-server to a fixed version for your release line: 8.6.3 or 9.3.1-alpha.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-27804 being exploited?

There is no known exploitation of CVE-2026-27804 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2026-27804, GHSA-4q3h-vp4r-prv2.

Is CVE-2026-27804 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free