{"answers":{"affected":"3 open source packages ship an affected version, including psd-tools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27809 in the wild and no public exploit code.","fix":"Upgrade psd-tools to 1.12.2 or later.","what":"CVE-2026-27809 is a medium-severity denial of service vulnerability in psd-tools, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27809 and fix it if it is affected.\n\nWhat it is: CVE-2026-27809 is a medium-severity denial of service vulnerability in psd-tools, published on 25 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27809 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- psd-tools (PyPI): affected all versions; fixed in 1.12.2\n- psd-tools (PyPI): affected all versions; fixed in 1.12.2\n- psd-tools (PyPI): affected all versions; fixed in 1.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27809/ (Markdown: https://insights.sbomify.com/CVE-2026-27809/index.md)","id":"CVE-2026-27809","markdown":"https://insights.sbomify.com/CVE-2026-27809/index.md","name":"CVE-2026-27809","record":{"aliases":["DEBIAN-CVE-2026-27809","GHSA-24p2-j2jr-386w","PYSEC-2026-2262","UBUNTU-CVE-2026-27809"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python PSD library","requires_auth":"none","summary":"A malicious PSD file can cause a crash in psd-tools due to unhandled exceptions during RLE decompression, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"psd-tools","vendor":"psd-tools_project"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"},{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"},{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"},{"id":"CWE-617","name":"Reachable Assertion"},{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to version 1.12.2, when a PSD file contains malformed RLE-compressed image data (e.g. a literal run that extends past the expected row size), decode_rle() raises ValueError which propagated all the way to the user, crashing psd.composite() and psd-tools export. decompress() already had a fallback that replaces failed channels with black pixels when result is None, but it never triggered because the ValueError from decode_rle() was not caught. The fix in version 1.12.2 wraps the decode_rle() call in a try/except so the existing fallback handles the error gracefully.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"psd-tools: Compression module has unguarded zlib decompression, missing dimension validation, and hardening gaps","id":"CVE-2026-27809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"calibre Vulnerable to HTTP Response Header Injection","id":"CVE-2026-27810"},"packages":[{"ecosystem":"PyPI","fixed":["1.12.2"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":null,"source":"GHSA-24p2-j2jr-386w"},{"ecosystem":"PyPI","fixed":["1.12.2"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":"pkg:pypi/psd-tools","source":"GHSA-24p2-j2jr-386w"},{"ecosystem":"PyPI","fixed":["1.12.2"],"introduced":["0"],"last_affected":[],"package":"psd-tools","purl":"pkg:pypi/psd-tools","source":"PYSEC-2026-2262"}],"prev":{"headline":"Mailpit is Vulnerable to Server-Side Request Forgery (SSRF) via Link Check API","id":"CVE-2026-27808"},"products":["psd-tools"],"published":"2026-02-25","related":[{"cvss_score":9.8,"headline":"Potential buffer overflow in psd-tools","id":"CVE-2020-10571","kev_date_added":null,"published":"2020-03-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["psd-tools"]},"summary":"A malicious PSD file can cause a crash in psd-tools due to unhandled exceptions during RLE decompression, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-27809/"}