{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27812 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-27812 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-27812 is a high-severity vulnerability in Wei-Shaw sub2api, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27812 and fix it if it is affected.\n\nWhat it is: CVE-2026-27812 is a high-severity vulnerability in Wei-Shaw sub2api, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27812 in the wild and no public exploit code.\n\nAffected product: Wei-Shaw sub2api. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27812/ (Markdown: https://insights.sbomify.com/CVE-2026-27812/index.md)","id":"CVE-2026-27812","markdown":"https://insights.sbomify.com/CVE-2026-27812/index.md","name":"CVE-2026-27812","record":{"aliases":["GHSA-vc2q-289v-74g3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"AI API gateway","requires_auth":"none","summary":"Attackers can poison password reset links via Host Header manipulation to take over user accounts in the Sub2API platform.","user_interaction":"not_required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sub2api","vendor":"sub2api"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Sub2API is an AI API gateway platform designed to distribute and manage API quotas from AI product subscriptions. A vulnerability in versions prior to 0.1.85 is a Password Reset Poisoning (Host Header / Forwarded Header trust issue), which allows attackers to manipulate the password reset link. Attackers can exploit this flaw to inject their own domain into the password reset link, leading to the potential for account takeover. The vulnerability has been fixed in version v0.1.85. If upgrading is not immediately possible, users can mitigate the vulnerability by disabling the \"forgot password\" feature until an upgrade to a patched version can be performed. This will prevent attackers from exploiting the vulnerability via the affected endpoint.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Sub2API Vulnerable to Password Reset Poisoning via Host Header Trust Issue, Leading to Account Takeover","id":"CVE-2026-27812","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"open_redirect","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"EVerest has use-after-free in auth timeout timer via race condition","id":"CVE-2026-27813"},"packages":[],"prev":{"headline":"Roxy-WI has a Command Injection via diff parameter in config comparison allows authenticated RCE","id":"CVE-2026-27811"},"products":["sub2api"],"published":"2026-02-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["Wei-Shaw"]},"summary":"Attackers can poison password reset links via Host Header manipulation to take over user accounts in the Sub2API platform.","url":"https://insights.sbomify.com/CVE-2026-27812/"}