# CVE-2026-27812: Sub2API Vulnerable to Password Reset Poisoning via Host Header Trust Issue, Leading to Account Takeover

> Attackers can poison password reset links via Host Header manipulation to take over user accounts in the Sub2API platform.

- **Severity:** High 8.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-vc2q-289v-74g3

## What is CVE-2026-27812?

CVE-2026-27812 is a high-severity vulnerability in Wei-Shaw sub2api, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sub2API is an AI API gateway platform designed to distribute and manage API quotas from AI product subscriptions. A vulnerability in versions prior to 0.1.85 is a Password Reset Poisoning (Host Header / Forwarded Header trust issue), which allows attackers to manipulate the password reset link. Attackers can exploit this flaw to inject their own domain into the password reset link, leading to the potential for account takeover. The vulnerability has been fixed in version v0.1.85. If upgrading is not immediately possible, users can mitigate the vulnerability by disabling the "forgot password" feature until an upgrade to a patched version can be performed. This will prevent attackers from exploiting the vulnerability via the affected endpoint.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-27812?

It affects 1 product.


Products: Sub2api Sub2api.

## How do I fix CVE-2026-27812?

No fix has been published for CVE-2026-27812 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-27812 being exploited?

There is no known exploitation of CVE-2026-27812 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27812 and fix it if it is affected.

What it is: CVE-2026-27812 is a high-severity vulnerability in Wei-Shaw sub2api, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27812 in the wild and no public exploit code.

Affected product: Wei-Shaw sub2api. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27812/ (Markdown: https://insights.sbomify.com/CVE-2026-27812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27812
- OSV: https://osv.dev/vulnerability/CVE-2026-27812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27812/
Summaries are generated and may contain mistakes; the official description above is the record.
