{"answers":{"affected":"2 open source packages ship an affected version, including terriajs-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27818 in the wild and no public exploit code.","fix":"Upgrade terriajs-server to 4.0.3 or later.","what":"CVE-2026-27818 is a high-severity server-side request forgery vulnerability in terriajs-server, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27818 and fix it if it is affected.\n\nWhat it is: CVE-2026-27818 is a high-severity server-side request forgery vulnerability in terriajs-server, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27818 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- terriajs-server (npm): affected all versions; fixed in 4.0.3\n- terriajs-server (npm): affected all versions; fixed in 4.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27818/ (Markdown: https://insights.sbomify.com/CVE-2026-27818/index.md)","id":"CVE-2026-27818","markdown":"https://insights.sbomify.com/CVE-2026-27818/index.md","name":"CVE-2026-27818","record":{"aliases":["GHSA-w789-49fc-v8hr"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"TerriaJS server","requires_auth":"none","summary":"An attacker can bypass proxy allowlist restrictions to access unauthorized domains, potentially reading internal data.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"terriajs-server","vendor":"terria"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"TerriaJS-Server is a NodeJS Express server for TerriaJS, a library for building web-based geospatial data explorers. A validation bug in versions prior to 4.0.3 allows an attacker to proxy domains not explicitly allowed in the `proxyableDomains` configuration. Version 4.0.3 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TerriaJS-Server has a domain validation bypass vulnerability in its proxy allowlist","id":"CVE-2026-27818","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Vikunja has Path Traversal in CLI Restore","id":"CVE-2026-27819"},"packages":[{"ecosystem":"npm","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"terriajs-server","purl":null,"source":"GHSA-w789-49fc-v8hr"},{"ecosystem":"npm","fixed":["4.0.3"],"introduced":["0"],"last_affected":[],"package":"terriajs-server","purl":"pkg:npm/terriajs-server","source":"GHSA-w789-49fc-v8hr"}],"prev":{"headline":"EVerest's ISO15118 update_energy_transfer_modes overflow can corrupt EVSE state","id":"CVE-2026-27816"},"products":["terriajs-server"],"published":"2026-02-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["TerriaJS"]},"summary":"An attacker can bypass proxy allowlist restrictions to access unauthorized domains, potentially reading internal data.","url":"https://insights.sbomify.com/CVE-2026-27818/"}